Virtualmin + Let's Encrypt + Cloudflare CDN Proxy = SSL ERROR

Hello everyone! As said I’m having trouble making to work my HTTPS website/s with Cloudflare, all hosted upon a local Ubuntu 18.04 + Virtualmin webserver.

Looked already through many other simillar topics, but no answer or no final solution was given. I’m having trouble identifying if it’s certificate, or server related.

Websites are currently working without Cloudflare CDN proxy.

https://gv5.gruporecrearte.nucleoservicios.com is working fine unproxied with Let’s Encrypt certificate, requested by Virtualmin (No CF Proxy).

https://ar4.gruporecrearte.nucleoservicios.com is NOT working proxied with Let’s Encrypt certificate (Proxy just enabled for this test/verification purpose ERR_SSL_VERSION_OR_CIPHER_MISMATCH).

https://lx01-lanus.nucleoservicios.com:8443 is Virtualmin’s UI. Which is working no errrors with a Virtualmin’s self-signed certificate and Cloudflare’s flexible SSL (CF Proxy on) [Although seems Webmin/Virtualmin doesn’t seem to run on the same websites’ Apache].

What I’ve tried so far is disabling SSL3 through Cloudflare, enabling TLS1.0/1.1 server-side (At the moment enabled at least TLS1.2), disabled and enabled CF’s Universal Certificate. All with same result.

As additional info, I completely disabled built-in DNS server from Webmin’s console as I prefer Cloudflare’s solution.

Thanks in advance!

1 Like

That keeps your site insecure. Fix the certificate and change to Full Strict.

Thank you very much @sandro, that was my exact issue!

Pleasure, but don’t forget to fix the encryption mode as well

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.