Video Streaming - Signed URL

Hi,

Video streaming using “Signed URL” just started to give this error message :

no video id or valid token found in path

Please help, all our users are shown this error message,

Is the service down ?

It works perfect without signed URL…

Thank you

EDIT : The correct error message was error “10009” with message “Forbidden”
It was due to my improper usage of the keys.

I was signing a new key each time there was a new video view, so i’ve reached 1000.

The solution was to list the keys, delete a few of them and get a new one, note the new keyid and the key in PEM format.

Now I use the same “key” and “key pem format” every time there is a view.

I dug here api(dot)cloudflare(dot)com/#stream-signing-keys-list-signing-keys
and installed # curl 7.76.1 for Windows from curl(dot)se web site to curl it straight.

I will see how it goes, hopefully everything will be ok !

Thank you everyone

1 Like

@renan was just on (EDIT: my mistake…it was an older post), but if you can open a ticket and post the ticket #, someone can probably take a quick look. The video ID might also help (or put it in the ticket).

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

The ticket number is: [2154789]

*Can everyone see my ticket or only Cloudflare staff,

Thank you very much !

Only Cloudflare staff can see it. So you’ll have to wait for either @renan or @zaid to take a look, or whoever else is on duty at the moment.

Hi, we’ll take a look and respond to your ticket. From my test, this doesn’t look like an outage and I am able to generate and use signed URLs. We’ll dig deeper into what might be up with your tokens and get back.

2 Likes

OK thank you Zaid !
This morning I tryed making another API Token but same error “Forbiden”.

I tried with “all account, or the specific account”.
I used : Stream:Edit as permission,
The date scope is ok,

I also confirmed that my Account ID was ok and it looks correct.

Thank you all for trying to help me. I hope we find what is happening.
*I’ll try my php test script on an other web hosting to see… (edit : Same result )

Just replied to your ticket and will continue follow up privately.

-Zaid

1 Like