Very slow (up to 1 minute) via Clouldflare vs a few seconds accessing the site directly

Very slow (up to 1 minute) via Clouldflare vs a few seconds accessing the site directly. I think it could be related with SSL, but I don’t know this for sure and and don’t know what could it be causing this or how can I fix it.
I tried switching most of the ‘Speed’ settings on and off. Same for the ‘Crypto’ settings.

The site has its own certificate. The site is configured as “Full (strict)”.

I tried with “Always Use HTTPS” on and off with same results, " Opportunistic Encryption" on/off, " Automatic HTTPS Rewrites" on/off, etc.

“Auto Minify” enabled/disabled, " Brotli" on/off, " Rocket Loader" on/off, and more…

Via Clouldflare the site could take up to 70 seconds to show up, vs a few seconds when accessed directly.
After this long delay, for some time it works fine (seconds for any page, via Cloudflare),

I also get an “F” for “First Byte Time” via Cloudflare, but not hitting the server directly.
via Cloudflare: https://www.webpagetest.org/result/181220_V4_55bd6632b15d7c464e560f429dfc4d27/

(notice the 3.358s was because the site was already loaded. I’ll try to get a test results of the ‘first time’ 60+ seconds load time and add it here)

Direct access: https://www.webpagetest.org/result/181220_NX_6173d717ae54391d0e9dbe03900f44e5/

Thanks

Just loaded the site and it loaded fairly quickly. The quote site also mentions similar speeds for direct and proxied access. You’d need to make it reproducible in order for one to be able to check for more details.

Usually this is not Cloudflare related however but an issue with the site.

Because I just loaded it
The problem happens after some time, and I don’t know why because the site is being pinged continuously.
To reproduce the problem, I have to access the site after no real person accessed the site for some time.

The “F” for first byte can be seen anyway, and it doesn’t happen for the direct access (it is “A”)

It does not make any difference if you loaded it or not. At least Cloudflare-wise, if there is actually an issue related to how recently you yourself loaded it it would most likely point to some code or content cache on your server, which expires after a while and then forces a new run upon the next visit. That is a case you’d need to check on your server however.

Regarding the first byte

Proxied access on http://sitemeer.com/#evotiva.com shows a significant faster response than direct access on http://sitemeer.com/#evotiva.com.dnn4less.net. That might be edge cache related however, depending on your caching settings.

100% sure it does. I’m tracking down this problem since many months ago.

In that case you might want to open a support ticket.

This topic was automatically closed after 30 days. New replies are no longer allowed.