Verifying router settings are working

Having configured my router as per the instructions, how do I now verify from one of my other machines that I’m using the right DNS server?

Hi @paul.hargreaves, take a look at this info and if you have questions or problems verifying post back. :slight_smile:

I also found this / may be helpful both for checking settings and overall router security.

F-Secure Router Checker
Router Checker is a free, web-based tool that checks your router’s settings and detects if it may have been hijacked by criminals. If your router is compromised, every single device on your network is at risk of being hacked.

1 Like

This may help expedite your new DHCP settings from the router by clearing the DNS cache.

Windows PC

ipconfig /release
ipconfig /flushdns
ipconfig /renew


sudo killall -HUP mDNSResponder


Dig doesn’t help; it was the first thing I tried.


$ dig
; <<>> DiG 9.10.3-P4-Ubuntu <<>>
[snip]		5	IN	A

;; Query time: 748 msec
;; WHEN: Mon Apr 02 07:59:56 BST 2018
;; MSG SIZE  rcvd: 100


$ dig
; <<>> DiG 9.9.7-P3 <<>>
[snip] 26	IN	A

;; Query time: 22 msec
;; WHEN: Mon Apr 02 08:00:36 BST 2018
;; MSG SIZE  rcvd: 92

( is the router)

I also tried the F-Secure but the ‘DNS IP’ returns an IP address from the same DSL provider I’m using.
That doesn’t mean the ISP is hijacking though, since cloudflare use them as a pop.

$ sudo ./ --expert -C -t A -s DNS:, hostname:, rdatatype: A
1	gateway ( 1.626 ms
2	 *
3 ( 27.947 ms

That’s still not conclusive however.

Try dig @ ANY

if it is Cloudflare under status you will see “status: NOTIMP,” as we don’t support the ANY query.

$ dig @ ANY
;; Warning: Message parser reports malformed message packet.

; <<>> DiG 9.10.3-P4-Ubuntu <<>> @ ANY
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25031
;; flags: qr rd ra; QUERY: 1, ANSWER: 50, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: Message has 2 extra bytes at end

;			IN	ANY


So I should assume then that it’s not working correctly in this case?

Are you by chance using dnsmasq? It might be intercepting DNS queries on the ubuntu box…

Is this test 100% conclusive? I did get a return of “status: NOTIMP,” after changing the router settings. Just wanting to confirm if there is any other test I should be running? Thanks in advance to OP for starting this thread and the everyone who has responded.

If you’ve changed your router settings (and your Client is configured to use the router for DNS) doing dig ANY (without needing to add @ should return the “status: NOTIMP,”.

I get the same response via OSX,
BTW, ISP is Vodafone UK, so not a small one. Not sure if there are other VF users who have already had a go, so that I can figure out if it’s ‘user error’ (router not working properly etc) or VF messing with port 53.

dig without adding @ returns “status: NOERROR,” same as @paul.hargreaves mentioned above.
; <<>> DiG 9.10.3-P4-Ubuntu <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52973
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 4, ADDITIONAL: 1
; EDNS: version: 0, flags:; udp: 4096
; IN A

;; ANSWER SECTION:		60	IN	A		60	IN	A		60	IN	A		60	IN	A

;; AUTHORITY SECTION:		2903	IN	NS		2903	IN	NS		2903	IN	NS		2903	IN	NS

;; Query time: 20 msec
;; WHEN: Mon Apr 02 11:39:27 EDT 2018
;; MSG SIZE  rcvd: 236

In my opinion, the fastest and easiest way to determine what DNS server you’re using is to use the Windows Command Prompt.

In Windows 10, right-click on the Start menu and click on Command Prompt. In most other versions of Windows, click on Start , then All Programs , then Accessories , and finally on Command prompt .

Type “ ipconfig /all ” followed by Enter . You’ll get a lot of information.

Not really, if the router is using, but you are going straight to the router you wouldn’t see there, but the local router’s IP.