Verify your human loop for 2 days

Hey, there is 2 sites I’m using that is using Cloudflare verify your human, I’ve now been in a verify your human loop for 2 days on my computer, what can I do?

I’m using Google Chrome, updated to the latest firm.

Things I’ve tried to do to resolve it so far:

  • tried deleting all cookies etc…
  • checked if my antivirus is blocking something, doesn’t seem like it as far as I can tell.
  • updated windows.
  • tried using VPN.

Can you share specifically what your browser and operating system versions are?

And can you list all of your currently installed browser extensions?

4 Likes

Hey, thank you for replying.

Browser version is: Version 111.0.5563.65 (Official Partial Version) (64-bit)
Operating system: Version Windows 10 Home
Version 22H2
Operating system build 19045.2728

Google chrome extensions:

Adblock 5.4.1
Avast online security & privacy 22.11.177 (installed yesterday)
Google Translate 2.0.12
Grammarly 14.1100.0
HTTPS Everywhere 2022.5.24
Metamask 10.25.0
Momentum 2.7.53
Torrent scanner 1.3.0
Trim 7.14

What happens if you disable those extensions? I would suspect Adblock and Avast looking at those, but I’d recommend disabling them all for testing, and then slowly enabling them one by one.

I tried to disable all of them, nothing happened.

I’m having this same issue while using multiple browsers on my Android phone (android 13). I’ve cleared cookies and cache, and disabled my VPN (adguard) and in-browser adblockers; nothing works. Please advise.

Hi @SimH and @cdm2023, could you share the ray ID that shows up in the challenge page?

Hi. Sure: 7a855ac968339aba

Thanks! Can you try with a different browser, e.g., Chrome on Android?

Where can I find the ray ID? it just reloads and when I click the Cloudflare logo it sends me to a Cloudflare site

I’ve also tried with another browser, Edge, no success.

Yes, I just tried it on my desktop computer and it worked. I then tried it on the Samsung Web Browser on my Android and it worked.

I always use the Soul Browser and haven’t had this issue until now. I’ve reached out to the Soul Browser feedback email. Hopefully they’ll respond.

I guess my other question would be if you were able to examine anything with that Ray ID? As in, maybe their security settings are too high and won’t work with certain browsers any more?

Installed Brave browser and tried there, it WORKED. Guess I’ll use that browser for now, I suppose it could be some issues with google chrome’s latest version

A post was merged into an existing topic: Cannot access sites

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.