Verify human loop

I didn’t know where else to put this, so I’m sorry if this is the wrong spot.

My husband and I have been getting the “verify human” loop for the past day or two. We can’t download some updates (Discord and PokemonGo) and we can’t access some websites, mainly logging in to play Runescape. Some websites seem to verify fine, but others don’t. This isn’t just on one device, it’s on two PCs, two tablets, phones, etc. I tried resetting the IP in the modem, I tried different DNS, the only thing that lets things work is if I use a VPN in a different country. I can’t find many people having this problem, other than one person that was on the barkbox subreddit.

We’re in the US and we use AT&T fiber for our ISP.

Hi @victoriaallen527 , this wouldn’t really be a Cloudflare issue, but lets try some suggestions.

You mentioned your service works if you use a VPN. Which VPN service are you connecting to, any specific region/state/country?

Does it work on your phone if you use mobile network (3/4/5 G) instead of your Wi-Fi?

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.