Valid IPV4 address is required

Hey all! I’m trying to link my custom domain to an IPV4 address, but i get the following error: Valid IPv4 address is required. I’ll add some screenshots and logs below.

I’m a new developer, and kinda dumb :smiley: Sorry

Logs: points to and has its traffic proxied through Cloudflare.
Valid IPv4 address is required

The Port is not part of an IP address.

1 Like

I require the port for the IP address. I am using a shared IP address, and my port is user specific. Any ideas?

What kind of service are you hosting on that port? HTTPS?

I am using HTTP.

HTTPS sends " sent an invalid response."

Please go to (select your domain) after you created the A record and change the SSL setting to “Off”.

Then go to the sub-menu “Edge certificates” and disable “Always use HTTPS”.

Last, go to (select your domain) and create an Origin Rule that changes the port to the one you require.


Huh? I cannot create the A record because I get the error “Valid IPv4 address is required”.

An IP address doesn’t have a port. Just put the IP address. You need to use the Origin Rule to redirect it to the port you want.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.