Valid certificate, but no connection with the site in HTPPS. Only done in HTTP

Hello everyone, and happy new year :slight_smile:

I have no choice but to come and ask for help, I am not an expert. I think that a technician / seller of my host voluntarily caused a problem connecting to my site

Let me explain,

He transferred two client sites, I never had a problem with Cloudfare
Lately, I wanted to transfer a third, but I forgot Cloudfare! He then offered me his Certificate at 60 € each year. I told him I couldn’t afford it, I asked how I did for the other sites

He then reminded me of Cloudfare (I must have been very tired that day!). I said with a smile that I was not going to pay at his place when I had free with Cloudfare. He then tried to sell by telling me that with his certificate there was a better quality and that he took care of everything for free in case of connection problem. I mentioned again that I preferred to use Cloudfare, which I did.

The problem is that despite an identical configuration for all sites, I have a big connection problem, of which I do not know the cause!

Indeed, this has never happened to me: if I want to visit my site in HTPPS, I have the certificate, but no site, as if the database was not linked :

By cons in HTPP there the site is there

Of course, he does not want to hear anything, he tells me that it comes from Cloudfare, and offered to ask me for a quote to repair. It tells me that it comes from cloudfare but the configuration is exactly the same for all sites

He laughs at me but I can’t say anything, do nothing, I can’t find the cause of the problem

I am French, I live in Ukraine, if someone can help me it would be great

thanks again


That’s a webserver configuration issue. Are both domains yours?

Hello, yes the domains are mine

This is what I say to this technician but he insists on telling me that the problem comes from a bad configuration of Cloudflare and offering to pay to repair, help

I don’t know what i can do, and if i can resolve alone :frowning:

It’s not the moment that i have a problem with my host and change server

OK. Try the following:

Set the DNS records on your dashboard to :grey: For your root domain and for www. Just click the orange cloud Icon.

Wait 5-10 minutes and try again. If it persists, you have the proof. In case you get a certificate warning, ignore it and continue.

ok, i did, i wait :
and i will reactive,

thanks a lot for the time you use for my problem


Yes, but check the site before you switch back :wink:

Nothing has changed, yet I put everything back

I am furious internally because I know that he has won, or that he wins, he is waiting for one thing is that I come to ask him for a quote to connect when I know that it comes from him

all because I refused his offer and told him that I preferred to pay nothing at Cloudflare and that I did not worry, I never had any worries

And now I have that and I have to deliver the site to the customer the day after tomorrow

Can it come from me? an error in the htaccess file? in the database?

It could be anything that’s hard to say. From webserver configuration (No vhost, wrong document root…) to a removed or changed index file. Hard to say without knowing the configs and other details from the host.

It would take time to dig into it. Most of us are volunteers who reply to posts in their spare time. So…

1 Like

I’m open to correction here, but:

Connecting directly to your origin it looks like there is no virtual host for your site on 443.

What is your current " Your SSL/TLS encryption mode" (its on the SSL/TLS tab on the dashboard? I suspect it is set to Full, so (temporarily) setting that to Flexible should make your site work while you sort out your hosting provider.

Can you try that and reply back?

1 Like

hi Michaël

thank you for your return
A michael who helps another michael :slight_smile:

I switched to flexible, the site was accessible in htpps but was not completely secure and many images did not have their normal shape / location / size. What does that mean ?

Flexible works that way that traffic between the visitor is encrypted but between Cloudflare and your server is not and therefore connecting via HTTP.

You need to configure your webserver’s vhosts to accept connections ob Port 443 and redirect it to the according document root for this domain.

Nice one @michael

1 Like

hi :smiley:

I am not stong for do it, can you confirm please, it’s the problem all will work after ? ='D


I sent your message for my host and will see if it was this or no, thanks a lot for your time that you gave for help me


Hi @michael hi @MarkMeyer , just one message for said you all is good now and thanks a lot :smiley:

For said you what it was, it’s was i told, 4 techniciens told it was bad config cloudflare, they took my admin, and told put mixt, what i told already and did,
And the nob found alone : it was Elementor : Just i should change urls old and new in settings Elementor, and after click on Regenerate CSS, and all worked :smiley:

When i see the conflict i had with techni and direction agence for said NO it’s not cloudflare and they told “4 techniciens said it’s cloudflare ! We are partners cloudflare we do 100 cloudflare all the days !” :frowning:

and it’s a noob found … :frowning:

Now, all is good, it’s the more important !

Thanks again for your help !
Have a super good continuation, years, and day !


Hi @michael , hi @MarkMeyer, and everybody ! :blush:

:cowboy_hat_face: I have a new enigma for you ! It’s a bit the same, since the title does not change, but a problem that never happened to me with Cloudflare, and on the creation of a new site (so no migration)

My current WP configuration

PHP / MySQL version : 7.2
Theme used : Ocean
Extensions in place :

Activity Log, Block Bad Queries (BBQ), Classic Editor, Cloudflare, Elementor, Elementor Pro, GDPR Cookie Consent, JetMenu, JetTricks, Simple Custom CSS and JS PRO, TinyMCE Advanced, User Login History, WP Maintenance Mode, WPS Bidouille, WPS Cleaner, WPS Hide Login, WPS Limit Login, WP User Login Notifier, Yoast Comment Hacks, Yoast SEO

Site address : Click here

:thinking: Encountered problem :

So, despite a configuration of my Cloudflare identical to all my other sites on the same server,

Despite a configuration of my domain identical to all my domains,

Everything works perfectly with the other sites except this new site linked to at the beginning of the message (I cannot display it, it is an institutional site)

Despite this I have this problem :

I have HTPP access to my admin, but not to my test home page which goes to HTPPS, and which instead gives me this :

This is the name of my server, and not secure

Then when I try to access the admin in HTPPS, I have this :

On the other hand, if I visit the site in not connected, I can see the home page, but in HTPP only (!)

I asked support, my server technicians, but they say everything is fine with them

Maybe, but since it’s not the first time it’s been my fault, and all things considered, no, well … I’m wondering.

Can someone tell me where the problem is, how come the connection is not working, where does it come from, and why do I see this? Why do we have this if I am logged in Admin and not just visitors where I see my page? Why when I see my home test page I don’t have the padlock, it’s not secure?

I remind you, each page of Cloudflare for this site is identical to other similar pages of other sites, the same for the domain, and this is the first time, and that I have just installed the database with these plugins used on other sites

I tested deactivated 5/10 min DNS and reactivate, I tested Flexible and Full, nothing changes
I checked also the connection data in WPconfig, I checked the htaccess, etc etc :unamused:

Thanking you in advance for your help, have a good evening


Update 10 min after :
Now everything is well configured, I have the admin in HTPP and the same site as Admin in HTPP.

By cons no seals, no padlock, I’m in “not secure”

Thanking you for your help

1 Like

It’s quite late over here and I may have missed something, but it looks pretty much like this one:

1 Like

lol)))) :sweat_smile: Hello

Yes, by the title, but it is not the same thing since the solution of the first does not change anything here.

Hi, juste for said i did NOTHING, but today all was HTPPS and the padlock was present :heart_eyes: :heart_eyes: :heart_eyes: :heart_eyes:

Maybe sometimes it takes time for this to be taken into account ? :thinking:

thank you to those who came to answer and have a nice day ! :cowboy_hat_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.