Using TLD .click with tunnels

Howdy. I am a bit stumped. I am experimenting with Tunnels and have found that if i use a .com domain, as soon as i hit SAVE the public address to the tunnel works immediately. I have a cheap domain pukekohe.click and when i use that for the tunnel, the public records fail to work. SO my question is, are only certain TLDs supported when setting up tunnels? is the TLD .click not usable?

Terry

Your DNSSEC seems incorrectly set. You need to update the DS records from Cloudflare to your registrar or turn off DNSSEC at the registrar.
https://dnsviz.net/d/pukekohe.click/dnssec/
https://cf.sjr.org.uk/tools/check?45df91f534b742f39da64b778540dcfd#dns

1 Like

Ahaaaaa. ok. I have removed the DNSSEC records from Route53 and will wait a while to see if that resolves the issue. Thank you so much for the tip!! Terry

Hiya, it does however appear that .click isn’t yet a supported TLD on Cloudflare. I suspect that may be the fundamental issue with using .click

Terry

You added the domain to Cloudflare and .click is in the public suffix list so it is a supported TLD.
What subdomain are you using for the tunnel? (There’s no apex or www record set for the domain yet).

OK, so i created a new .net domain and used that instead and it works immediately, with no apex or www record set. I really do suspect that the .click TLD doesn’t work with CF Tunnels.

I tried to re-create the tunnels using pukekohe.click TLD and i cannot access any resources. Flick back to new domain i***n.net and it works fine.

Terry

Okey Dokey. Mr SJR, it does actually seem that the DNSSEC setting i had on AWS Route 53 was messing this up. I deleted the DNSSEC setting and now approx 24h later, the .click domain now works with CF Tunnels. Thank you so much for the tip.
Terry

1 Like