Using the APO but still my site sometimes response very slow

I am using the APO plugin and my site works pretty fast. But sometimes especially in the morning when my site is still “sleeping” the first time I try to attempt it and it loads extremely slow (5-10 seconds). Is there a way I can fix that?

See if caching is working. Look at the “cf-cache-status” header to see the status. HIT means Cloudflare is caching.

Hi,
The cf-cache-status is HIT and the site still loads extremely slow the first time i attempt it. Would you recommend some changes?
Thank you

The first hit will always be uncached. When a user visits the URL, it will be cached to the edge. Maybe you have a rule that clears the cache every 12 hrs or 24 hrs. That could explain why only you are facing issues only in the morning. Maybe look into Cache-Control.
OR it could be anything like scripts, images, CSS, or even your browser which could be the problem.
Test from different browsers and incognito.
It would be helpful if you could share the URL.

Can’t find the Cache-Control settings. I’ve tested with different browsers, on phone, on desktop…problem remains. Maybe I need to upgrade to the PRO plan? The site is Legit.Casino.
Thank you

cf-cache-status: DYNAMIC
It should be HIT. Are you sure you have enabled APO? Do you have the Cloudflare plugin installed?

I was in development mode. Please check now.
Thanks

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.