Using Heroku with Cloudflare

dns

#1

The domain points to the Cloudflare nameservers, but it keeps showing an 1016 error. I already contacted the support desk of Heroku, but the domain is resolving correctly on the Heroku side. Please help me out here.


#2

Have you tried following this guide?


#3

Yes, the Heroku support team shared this with me. I also send them screens of the Cloudflare dashboard and they couldn’t find anything wrong. I am really stuck.


#4

Have you tried contacting support at support[@]cloudflare.com?


#5

Not yet. First tried the community.


#6

I have never used Heroku, if they don’t find errors on you config, try contacting support…

Is it possible that you misspelled something in you CNAME record?


#7

Just double checked, but no typo’s


#8

The support is the way I think, they can see what error you are seeing, we (most of us at least) do not have that access), maybe @ryan can help!


#9

No response from the support team and don’t know why I see an 1016 error.

Also checked the troubleshooting https://support.cloudflare.com/hc/en-us/articles/234979888-Error-1016-Origin-DNS-error


#10

Alright, fixed thanks to the Cloudflare support team. @matteo, it was a typo (- instead of .) :expressionless:

Thanks for the support!


#11

This topic was automatically closed after 14 days. New replies are no longer allowed.