Using Duo Security as 2FA - how to reset it to use it on a new phone?

2fa

#1

Hi there! I use Duo Security as a 2FA single-use password generator for Cloudflare. It has worked flawlessly ever since I’ve configured it… until today I upgraded my iPhone to a more recent model. While the Duo application correctly identifies that I use it for Cloudflare, since the original configuration was tied to the older iPhone, the new one requires a new confirmation/registration.

But CloudFlare, to allow any changes/modifications of the 2FA device/system that is tied to the account, needs some extra authentication… from the original device/system used to set it up on the first place… which sort of makes sense… unless, of course, you don’t have it any more!

So how can this apparent paradox be solved?

Other applications give alternative options to ‘reset’ the 2FA system in use, such as providing a QR code to scan, or a special sequence of numbers to reset the app used to generate the single-use code combination. But sadly Cloudflare doesn’t have any such choice on their backoffice…


#2

You will probably need to email support and request that 2FA be disabled. Then you can set it up again on the new device. Make sure you email [email protected] from your account email address and ask for 2FA to be disabled. If you let me know the ticket number I can get the ball rolling.


#3

Thank you so much, @ryan; I’ve opened a ticket as per your suggestion: #1450775. Fortunately, the backoffice cookie expiry date on this browser must be a significant amount of days in the future (I don’t know which of the many cookies is used for keeping the session alive), so I’ve still got backoffice access for a while, but, of course, this can be revoked as soon as the respective cookie expires…


#4

Whoops. Cookie expired today! That means I’ve lost access to the backoffice — and of course also to the ticket/support system. Maybe I should make a new request?


#5

You can still email them (support AT cloudflare DOT com) from your account’s registered email address.


#6

Look for a reply from support with further instructions.


#7

Thank you! Unfortunately I was away from the computer for the past couple of days and only managed to reply today!


#8

Just to add a note that this issue was fixed :slight_smile:


#9

:yay: