Using (no www) with DNS of Hosting Partner

How can I get my domain to work as “domain. com” with Cloudflare when activated via a Hosting Partner? Right now I only get CF headers when accessing over www. And if I set the domain as (and www redirects to domain. com) I see no CF headers. Is this possible when using a host’s nameservers?

So…not possible I guess.

Going through Hosting Partners can prevent use of the naked domain. Since “www” works, you can redirect over to with a Page Rule:

Match:* and Forward it as a 301 to$1 (or http if you don’t have SSL enabled)

Thanks, giving that a try.

I only see CF headers when I then request www. domain. After that CF headers disappear when clicking around teh site.

Anything at should have Cloudflare headers. If you’d like me to take a look, post your domain’s URL.

Thanks for this. Was fighting with it for a while tonight but this finally worked. Thank you very much for your help!

2 Likes shows CF headers. But if you click on a link and inspect headers there is no CF.

This is just a test site.

That’s because the www is going through Cloudflare, but the non-www is not. Since you’re using Wordpress, can you use the General Settings and change the site’s URL to the www domain? Or do it in wp-config.php.

I’m having the same issue. I had to disable the CNAME DNS record pointing to Cloudflare because an HTML5 ad was displaying images via but not

Would love to have Cloudflare managing the load but at this point I didn’t find any good solution for the issue :frowning:

Partner setups often require you to use a www domain, so I frequently recommend a Page Rule that redirects* over to$1

Then make sure your website is set up to use the www URL.

I can easily set the domain to work with WWW. But the whole point of this exercise was to see if I could get CF working with the domain with WWW through a partner plugin. Looks like that is not possible?

I’ve not used partner hosting, but it seems that some partners just won’t configure your site to work through Cloudflare without the www. This is because a non-www DNS record is technically supposed to be an A record IP address, not a CNAME, and that’s not how partners configure the Cloudflare link.

Here’s the long and short of it:

Regarding your Hostnexus setup, I don’t know why it’s returning your origin IP address for non-www, but using Cloudflare for www.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.