Using Cloudflare with 3dcart (settings supplied by 3dcart do not work)

I need help figuring out where our configuration is going wrong, then how to fix the issue(s).

Here are the basics:
• Ecommerce site run through 3dcart
• Hosting provided by GoDaddy
• Domain name registered through GoDaddy
• SSL purchased separately and installed through 3dcart so that all pages, not merely data-specific ones (the only ones covered by 3dcart default SSL) render as secure (don’t give a not-secure warning; seemed to be scaring off clients when the home page’s URL had “not secure” before it)
• Email run through GoDaddy, not 3dcart

3dcart Support said that because we run our email through GoDaddy rather than 3cart’s servers (I think I have that language correct), we need to do the following:

  1. Create a free Cloudflare account (done—for both + separately my own domain; I’m logged in here via the latter account, so thought I’d mention that)
  2. Cloudflare will automatically create your existing records (yes, it did)
  3. Point your nameservers to Cloudflare
  4. Change the A record for the main domain to a CNAME - @ - and point to

Steps 1 and 2, no problems. But after I do step 3, eventually the site goes down EVEN AFTER I also do Step 4—and the second time I tried I even had 3dcart Support on the line to make sure I was doing it exactly right. Nope, site stayed down. The only way I could get it back up was to change the nameservers back to the GoDaddy ones, at which point the 3dcart support person told me I’d have to talk to someone at Cloudflare, that they had no idea how to fix.

Anyone know where such a seemingly easy process is going awry? Is it the global SSL, or maybe the email hosting, that’s causing the wonkiness? 3dcart says the transition to using Cloudflare must be completed by Sep—which is 3 days from now! I am an independent contractor (a brand manager who also codes but isn’t a true webmaster) and was only sent the notice yesterday.

Help much appreciated!

Hi @sdent

Did the site throw an error message?

I should have taken screenshots. I tried yesterday evening to recreate the errors at each phase so I could take screenshots, only now when I change the nameservers back to the Cloudflare ones, my Cloudflare admin page doesn’t update quickly like it did when I first opened our free Cloudflare account (despite browser cache clearing, waiting an hour, two hours, etc); didn’t refresh until the next morning (this morning), at which point our site was back down. Guess I need to swallow that the site will be down for a bit, right, because people need to know the error messages in order to help me?

It is difficult to troubleshoot without an error! To start with, can you post a screenshot of the DNS app in your Cloudflare dashboard so we can check that? You can blur out any IP addresses there.

Currently the site works on, but not on which gives ERR_SSL_PROTOCOL_ERROR. This may be the issue, you may want to create the CNAME for www, not @ and then Redirect to, but I don’t know, given that they specifically told you to create the record for @.

Right you are. And that goes with my suspicion that our global SSL is a factor. Let me try your suggestion (I think I understand it). (I have to log out here, then log back in under my client account; I’ll figure out how to clear that up later.)

I find it odd that before changing the nameservers to Cloudflare I had 3 A records within GoDaddy DNS Management, none of which ever showed up in Cloudflare’s DNS list (unlike the first time I tried everything yesterday). Is that normal?

You can share access from the client account to your own, if you want.

Sometimes not all records get copied across as Cloudflare can’t query every possible record.

I would also suggest that you switch all DNS records in Cloudflare from :orange: to :grey: (if you haven’t already), for now, so Cloudflare isn’t interfering with anything. It will then be providing DNS only.

That was exactly my next question: The site is now working (thank you!!!) but all clouds are grayed out. Is that what we want? Here is a screenshot:

No problem, thanks for the screenshot.

I see an SSL error on the site, currently that is coming from their side.

This server could not prove that it is ; its security certificate is from * . This may be caused by a misconfiguration or an attacker intercepting your connection.

Which is surprising given that it was working before. They also seem to return a 404 for the site. You should probably contact them about that now as it seems to be set up OK at this end following their instructions.

With everything :grey:, Cloudflare is not affecting anything except the site’s DNS, so nothing SSL related on this end. Once the site is working, you can then look at :orange: to benefit from Cloudflare’s other services.

Makes sense—on all. I think the pointer that 3dcart told me to use—(domain)—isn’t correct for us, because that was the URL our visitors used to get forwarded to when visiting pages that involved data exchange (meaning pre-global SSL). I will check! And thank you for the info about adding my main email as an admin for the dominiquecohen Cloudflare account; worked!

1 Like

No problem, sorry I couldn’t help further. I agree that they may not be the correct instructions for your case. Have you tried with the DNS records that got pulled through from GoDaddy by Cloudflare, originally and the ones that were being used before you changed the nameservers? I guess these may work…

Oh, I didn’t know I could do that (this is still sdent, merely now logged in from the dominiquecohen account). I’ll try that now.

There isn’t a ‘button’ to restore the originals, but you should be able to find them in GoDaddy and see if that works.

I took a screenshot before changing the nameservers :slight_smile:

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.