Using cloudflare ssl with new install of wp on an .app tld


#1

I have a domain with an .app tld. I understand that this requires SSL.

I’ve tried multiple ways of getting wp installed but am unable to get access to the site due to “insecure connection”. Or… if I try to manually install SSL using the private key etc. from cloudflare, the softalicious installer tells me that no valid SSL certificate is found (even though I see it there in the SSL manager section of Cpanel).

Anyone aware of a 1-2-3 solution for getting wp installed on an .app domain? Thanks.


#2

The first step would to be to set the website up without Cloudflare, and get it running with its own SSL certificate. As soon as you initialize that domain at your web host, your second step should be to install SSL.

Once that’s done, it should be a pretty easy transition to Cloudflare with SSL.


#3

Thanks. The prob is that if I set up the SSL certificate first (using the CF key etc), then my choices are (a) to install WP using http (which works for the install but doesn’t do anything to solve the browser warning). The other choice (b) is to install using https… but Softalicious won’t allow me to proceed due to “SSL Cert not detected.”


#4

also… the “app” tld apparantly is part of the prob. I can’t install wp without a SSL, because the site resolves to https. (Even if I install as http)


#5

The .app tld is HSTS only - meaning it can only be loaded over HTTPS. See this blog.google post for information why.

Make sure the subdomain or zone you’re trying to use it on is :orange:, and either create a page rule with ssl: flexible or change your global domain setting to flexible SSL. This will connect via http to your origin, but HTTPS will show in browser and should allow you to access the domain.


#6

Thanks Judge. If it matters, in my Cpanel the domain is an “addon” domain (same as all my other domains with this host). In my CF DNS settings, the orange cloud icon is there for the A record for the domain name. The only other orange icon is at the CNAME www. The rest of the clouds are gray.

The global domain settings at CF are set at Flexible. And I still am not able to access the site via a browser.

Is there something I should add to .htaccess? Or add another DNS record of some kind?

And should I leave the manually pasted SSL and Key data with my host’s SSL configuration, or delete them?

THanks for your help
.


#7

The problem resolved itself overnight. So I guess I just needed to wait for propagation.

I’m going to post another semi-related question now.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.