Use Cloudflare with Emby

I can’t make Cloudflare work with Emby. Has anyone had any success with this?

My Emby server is self-hosted on an Ubuntu Linux host. I’ve tried every conceivable combination of settings and tried following every bit of advice I could find by searching the web, but no joy.

Does anyone know if there is a document that gives the Cloudflare configuration to use for Emby?

If this is the media server described here:

It does not use ports that are proxied by Cloudflare:

Thanks for your quick response. Right, I was trying to use port 8920, so I just now switched it to port 2096, which is one of the supported HTTPS ports on the list. Made the change in Emby, in the router, and in the firewall. However it still produces the same result. I can navigate to the site directly using https://:2096 and it works just fine. But when I try https://:2096, it gives the error: “Did Not Connect: Potential Security Issue Firefox detected a potential security threat and did not continue to . because this website requires a secure connection.”

Does Firefox offer more info on why the connection wasn’t secure? Have you tried a different browser? How do your SSL/TLS settings here look? Like it’s activated?

That hostname is not proxied by Cloudflare. It’s probably set to :grey:. Set it to :orange: and you should be set.

Doh! Yeah, I’ve been adding and deleting that A record to troubleshoot. Added the A record and it now works. Thanks for your help! I was stuck on this for a long time and could not have solved it without your help!

BTW, I’m deleting one of my earlier messages to remove the actual URL from our dialog.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.