Url with accent return 404 in CF CDN

Hello
I have some url with accent in my wordpress site.
For example https://www.mydomain.com/rénale/ which is so https://www.mydomain.com/rénale/
My website is hosted on siteground and it uses the worker sg_worker which is provided by siteground on the SGoptimized plugin.
When i enable the cloudflare cdn, url with accent return error 404.
When i bypass cloudflare cdn and url with accent are served from the original siteground server and don’t get the 404 error.
Does somebody have a solution to fix that? Or should i rewrite all my urls with accent?
best regards

A post was merged into an existing topic: Route for worker