URL redirection issue in page rules

I have my domain pointed to the Cloudflare Nameserver:

DNS setting:
A @ Proxied/Auto
A www Proxied/Auto

SSL/TLS encryption = Full
Always use http: enabled
Automatic https rewrites: enabled

I want http://mydomainincloudflare.com/this-is-my-post to 301 permanent redirect to my domain which is hosted in Bluehost server to URL https://myhosteddomain.com/this-is-my-post.

I set page rules for that:

301 permanent redirect

Destination URL:

But this haven’t worked. It always shows 404-page error.

But when I tried to redirect http://www.mydomainincloudflare.com/this-is-my-post to https://myhosteddomain.com/this-is-my-post it works.

How can I solve this issue?

Get rid of the scheme in your Page Rules maches. You don’t need the http or https. It’ll match both.

If you need more specific advice, please post the actual domain name.

When I try https://www.appliedmarketinggroup.biz/why-your-brand-needs-an-instagram-video-marketing-strategy.html, I get a 522 timeout.
Without www, I get a 404.

Maybe I’m doing something wrong, since I can’t get ‘www’ to work, but you can.

I don’t want for www . I just want to open https://techpawn.net/why-your-brand-needs-an-instagram-video-marketing-strategy-html/ when someone click in this url http://appliedmarketinggroup.biz/why-your-brand-needs-an-instagram-video-marketing-strategy.html . I don’t want to do anything with www .

I want to open this url https://techpawn.net/why-your-brand-needs-an-instagram-video-marketing-strategy-html/ when someone click on this url http://appliedmarketinggroup.biz/why-your-brand-needs-an-instagram-video-marketing-strategy.html. I don’t want to do anything with www.

Hi @sdayman , Can you help me fix the issue?

I am not able to fix this.

I don’t know how it is showing 404 error page ( I haven’t hosted it either , it contain dummy IP4 address as mentioned above in DNS record ) .

Url starting from www only works and get redirected, http and https version doesn’t work alone.

Seems like only www.appliedmarketinggroup.biz works in Cloudflare, other are not working any how.

(I have setup exact similar setup for another domain, and it works for all schema.

And Nameserver is setup correctly and it is only redirected to Cloudflare, other fields are empty.

I don’t know how to fix this problem. I have searched all over the internet but haven’t found any solution.

Was appliedmarketinggroup.biz ever hosted anywhere?

Just to be safe, try Liberate The Host for appliedmarketinggroup.biz and www.appliedmarketinggroup.biz

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.