URL Redirected too many times

Hi,

I’m trying to connect my Webflow site to storecloud.org (domain provider is Cloudflare). It looks like I added the right A and CNAME records but I’m getting errors and the site is not showing up at that URL.

Please help! See image link here: https://imgur.com/IpqnoPg

Which shows:

  1. TOP = DNS Settings
  2. BOTTOM = Webflow instructions to connect domain

storecloud and www look to be working independently, as neither redirects to the other. That usually doesn’t happen, as site owners choose one or the other for their canonical URL. If this is not correct, you’ll need to add a Page Rule to redirect one to the other. Here’s a tutorial with a Page Rule example (you can disregard adding a DNS entry, as you already have that).

The other part is the redirect loop. It’s bouncing back and forth between http and https. Was your site working with HTTPS before you added it to Cloudflare? It needs to be configured for HTTPS at the origin.

@sdayman thanks so much for your reply. I added the Page Rule you suggested as in the example and no luck.

To answer your question, on the Webflow side I am able to choose either storecloud.org or www.storecloud.org as the default domain. I’ve tried both and still not working.

If you look at the image I posted earlier, Webflow is giving me an error saying I need to remove the AAAA record from your DNS settings to ensure your site loads properly…I don’t see a AAAA record in my DNS settings.

Your help here is VERY appreciated

The page rule was the easy part: Point your site to use the canonical URL (non-www)…which is currently broken.

I suggest you edit your storecloudORG entry so it’s set to :grey:, then wait five minutes for that to take effect. After that, get that site working with HTTPS.

The :grey: is a direct connection, so you won’t see Cloudflare’s AAAA address for it. It could be that webflow just doesn’t want you using Cloudflare…but it’s still worth a try. Set it back to :orange: once you get it working with HTTPS. And make sure your TLS/SSL setting here is Full (Strict).

@sdayman can you re-explain your last message a bit more clearly please? I’m not familiar at all with Cloudflare

In the DNS tab here, click on the “A” record for storecloudORG. That will open up the editor so you can click the :orange: and switch it to :grey:. Then SAVE and wait five minutes to take effect.

@sdayman thanks for clarifying!

It seems to have done something, but still not working just yet…

It looks like it’s redirecting to ‘www’. I guess you’ll have to :grey: that one as well until the issue gets resolved.

@sdayman do you mean do that for the CNAME record? I did that recently and still getting the “ERR_TOO_MANY_REDIRECTS”

Everything needs to be :grey: DNS Only (or "Pause Cloudflare on Site from Overview page) until you get the site working properly with HTTPS.

This topic was automatically closed after 30 days. New replies are no longer allowed.