Url redirect not working

Hi,
I’ve a domain which I redirected with the page rules. But it doesnt work.

ERR_NAME_NOT_RESOLVED
Domain: rmm-flat.de

when I enter https or www everything is working fine.

These are my page rules:

Do you have an A, AAAA or CNAME record for the rmm-flat.de domain?

For the rule to work, you’ll need to create one, you can use an A record to 192.0.2.1 (an IP reserved for examples, but it can be used here as a placeholder), or you can point to your own server or elsewhere. Once such a record exists and is marked as proxied :orange: through Cloudflare, the request will hit Cloudflare and the page rule will kick in.

You should be able to use a single rule, you don’t need a separate one for the https:// version, but that’s an aside that doesn’t matter until you get the needed DNS record updated.

1 Like

hi,
yes - I’ve the following settings

@thedaveCA I have no idea what happened… but now I’ll get “ERR_TOO_MANY_REDIRECTS”

I’m not seeing a loop here, all the redirections chains I see end up at https://www.rmm-flat.de which gives a 200 response and delivers the page itself.

It could be that you already fixed it, or maybe something somewhere in the chain has a bad redirect cached, browsers tend to hold on to redirects sometimes. Can you reproduce in your browser’s Private Browsing mode?

Okay - I solved the issue with the too many redirects…

this is my setup now…

but I still have the error when I try to access rmm-flat.de w/o www or https

You need some A, AAAA or CNAME record for the root of the domain, rmm.flat.de itself and this record must be :orange: for page rules to work.

I recommend 192.0.2.1 because this won’t forward the requests anywhere else, you’ll just get a Cloudflare error until you enable a page rule to do the redirection for you.

You shuold only need one pagerule, the one you have enabled in your last screenshot is the one (no need to specify the protocol), but, this only works if the request hits Cloudflare.

done. but the error is still there

That is weird, I don’t see the redirect loop via curl but I do in a browser. Odd as I would expect them to be the same. What happens if you turn off the page rule, does that fix it? Are there any other page rules?

I have no idea - but now its working fine…
anyway… @thedaveCA many many thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.