URL record in dns does not work

I want to know why the url record I added in dns didn’t take effect?
It has nothing to do with the dns cache taking effect.
Because it’s been a long time (at least a few weeks now).

dns : Type = url , Name (required) = ww , Priority and Weight are both 10 , Target = https://www.example.com .

I asked my registrar and the answer I got was: “We don’t have any restrictions”.
My domain name suffix is: .hk .

Or is it a restriction from the registry? But I think there should be no .
I don’t really want to create urls via waf or whatever unless I have to.
I need to create url in dns. not rules or waf

That’s because that field is not a URL record that’s a URI (Uniform Resource Identifier)

If you’re trying to do URL forwarding you need to set a rule for that. It’s done in the dashboard for the domain name in question in Cloudflare under Rules → Page Rules.

Wow, is that so?

I always thought it was the url record,
it turned out to be the uri, didn’t notice.

In my commonly used dns resolution service providers,
they can add dns url records (ie dns 301 or 302).

Is this not allowed in the dns protocol specification?

Those are not DNS level redirects that’s just an interface choice that that registrars made with their included DNS.

They’re seamlessly setting up A Record and CNAME record to a web server they control where they set up the redirects for you.

301 and 302 are HTTP response status codes and those need to be handled at the web server end.

It turned out to be so. Got it, thanks a lot

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.