URL Masking Question

1.) I have mad an exact copy and paste of this code. I have set it to the route www.bdiq.com/directory

2.) In the preview of the worker it seems like it works correctly

3.) When I access in chrome it shows me a redirect to the URL https://agencies.partnerpage.io

Do you see that same behavior with this? (I’ve attached some screenshots to explain)

For me works fine set as default.

Two questions.

  1. Is it currently working for you? Because for me it gets into a redirect loop (and ends always on the HTTP version).

www.bdiq.com -> www.bdiq.com/directory -> www.bdiq.com/directory/ -> www.bdiq.com/directory -> …

  1. do you have always HTTPS enabled in the SSL/TLS settings? what is the current setting for SSL in the same page?

Matteo, I’ve got it all working now thank you for your help.

The issue I had was with the route and trailing slash on the URL.

For the trailing slash, django uses it, but I think that Cloudflare is dropping it and then django redirects again to the url with the trailing slash… this causes that redirect loop.

I changed the route to be www.bdiq.com/directory* and that was enough. Also made some configuration for cross origin on the server but the rest seems good!!

Thank you Matteo!! What a relief to get this set up :slight_smile:

1 Like

Glad everything worked!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.