URL forwarding; how do I know if my free zone is "for DNS only"?

I set up a free CF zone for one reason: I have a domain registered with another company, and I need to forward all traffic to another website. I changed the nameservers. Then I added the URL that I want to drive traffic to, but when I enter my domain name into a browser, I get the “Hm. Having trouble finding that” error message.

I saw that “Page Rules” do not work for zones that are being used for DNS only. Is that my problem? What does that mean? And how do I fix this?

Please note: I am not good at this. None of this stuff is familiar to me. Please be kind. :slight_smile:

Welcome to the Cloudflare Community. :logodrop:

You will know a DNS record is DNS Only by the :grey: next to it. Page Rules only work with Proxied names. They will have :orange: next to them.

It is a lot easier for the Community to provide you with specific answers when you share your domain name. That will allow us to look things up on our own.

Wow - that was quick! Thanks. My domain name is lerissapatrickvoicedot com. The target URL is apps.voiceoverviewdocom/lerissa_patrick (with https: slash slash in front).

I couldn’t figure out the “preformatted text” option.

Where would the orange (or gray) cloud appear?


You can use the </> button in the message composition menu, or just type a backtick before an after the word or words. If you type `example.com` it will appear as example.com.

You will find them in your Cloudflare dashboard DNS app for that zone https://dash.cloudflare.com/?to=/dns/records

You appear to have not created any DNS record for your apex name, proxied or otherwise.

You will want to add an AAAA record for the name @ with the special discard IP of 100:: and make sure to leave it :orange: . Once saved, the @ record will appear as your apex name in the list. That is normal.

Okay! I added a AAAA record. It looks like this:

Type - AAAA
Name - </lerissapatrickvoice.com> (I typed @ and it filled in the rest)
Content - 100::
Proxy status - Proxied (orange cloud, but with a gray line behind it)
TTL - Auto

But when I typed </lerissapatrickvoice.com> into the browser, I got Error code 522 (“initial connection between Cloudflare’s network and the origin web server timed out”) and something about the host “is not completing requests.” That means </voiceoverview.com> isn’t working - right?


Not exactly. Did you not already create your redirect rule?

Yes, I created it via Page Rules. This is what the summary says:

\www.lerissapatrickvoice.com\ Forwarding URL (Status Code: 302 - Permanent Redirect. Url: '\https://apps.voicerview.com/lerissa_patrick)

And the green slide is checked.

In Redirect Rules, they use “URI” where I would expect to see “URL.” What does this mean?

That rule matches www.lerissapatrickvoice.com not lerissapatrickvoice.com. You don’t have any DNS records for www. Repeat the earlier step for adding the AAAA record of 100:: using www as your hostname this time. If you want both www and the apex name to redirect, you can update your Page Rule to match *lerissapatrickvoice.com. That will match both the apex and any subdomain.

In Redirect Rules you are seeing uri.path which is the part to the right of the domain name. You will only want to redirect with Page Rules or Redirect Rules, not both. You can stick with the Page Rules for now since you are already using them.

1 Like

I don’t seem to have a zone for the domain \www.lerissapatrickvoice.com\

Do I need to create that and delete the domain \lerissapatrickvoice.com?

When I type www in the Name field to add a AAAA record, I get \lerissapatrickvoice.com.www.lerissapatrickvoice.com \

I’m lost. Maybe Cloudflare is for people who already know what they are doing …

Try using a backtick ` instead of a backslash \ and you will actually wind up with preformatted text.

You won’t have a zone for www.lerissapatrickvoice.com. The zone is lerissapatrickvoice.com. You need to create a hostname for www just like you did for @.

Anything is certainly going to be easier if you already know what you are doing. That’s one reason people hire experienced professionals so they can spend their time on things they find more valuable.

You can definitely delete that one. It’s not going to do you any good. Try adding a AAAA record with only www as the name.

I tried adding a AAAA record with only www and it gave me www

Maybe I’m not on the right page. I am here:


The page lists required steps to complete zone setup, and the first one is to add an AAA record for www so that </www.lerissapatrickvoice.com> will resolve.

Then it says </www.lerissapatrickvoice.com> points to 100:: and has its traffic proxied through Cloudflare.

So doesn’t that mean I already have an AAAA record for the www URL? no?

When I type www in the Name (required) field and 100:: in the IPV6 address field and then hit Save, the result is

Type: AAAA
Name: www

Can you post a screenshot? DNS queries directly to Cloudflare’s public resolver at return no records for www.lerissapatrickvoice.com.

It’s showing up now and your www redirect works. You may want to make adjustments so that it redirects without www too.

It’s not working for me. This time, when i typed in the full URL (with www), I got the Bing error page - couldn’t find it.

Try incognito.

You may also have a locally cached negative DNS response.

I tried incognito. Nope … should I empty the cache?