URL being stripped out when I save CNAME record

I added DNS records so Stripe can verify my domain ownership. One CNAME record (bounce.omnistrat.com) isn’t saving correctly because Cloudflare is stripping out my URL.

I found a solution in the Cloudflare community (Cannot create CNAME for Stripe), but I still can’t get it to work. Although, this solution seems to be for when you paste into the field the URL is being stripped. My issue is when I save the record the URL is being stripped. The community solution was to cut and paste into a text editor and then cut and paste into the DNS manager. After doing that and then saving Cloudflare still strips out my URL.

I’m non-technical, so apologies if I’m missing the obvious.

Ahhh…no worries…it’s still there.

DNS here only shows the domain name (example.com) if that’s all that’s in the record. A subdomain, such as “bounce.example.com” won’t show the example.com part because it takes up too much space.

As for Stripe not liking it, make sure that CNAME is set to :grey: so it still resolves as a CNAME. When Cloudflare proxies (:orange:) a CNAME, it converts it to an “A” record (IP Address) in order to proxy that traffic.

Thanks, sdayman. That’s helpful to know. Now I have to figure out why Stripe can’t validate. Stripe did say to toggle-off proxies for all the dns entries, so that’s not the issue.

I did a dns lookup and no cname records came back. That seems like an issue, but not being technical I don’t know. I’ve added plenty of dns records and all my other service vendors validated. Stipe is the only one that’s gotten stuck.

It’s a simple cut and paste operation to make it virtually idiot-proof. Stripe also gives me a notice that my dns entries are correctly entered (if it know that why isn’t it validating?). So having done it “right”, why the issue? Weird that no one else experienced this issue. I can’t be the only Stripe user in Cloudflare. So what could I be doing wrong?

That CNAME is valid, but are you sure it’s supposed to point to “custom-email-domain”? Or was that just placeholder text?

Ahh, we have discovered the idiot. I was so careful to cut and paste everything so there were no mistakes I missed that. Surprising the Stripe instructions don’t mention that. I just fixed it and all the records were accepted, but the edited one. I’ll have to wait for propagation and try again. I assume I’m all set know. Thanks, sdayman!

1 Like

sdayman,

It’s still not validating. The alert message Stripe gives me is to reenter the cname record (the other seven entries pass). I saw the below note in Stripe’s troubleshooting section and based on what you said maybe I need to just add bounce without my url after it?

  • Ensure the added record names do not include your domain twice. Some providers automatically append DNS record names with the domain name. In this case, if we ask you to create a record with the name “bounce.example.com” you must only enter “bounce” into the name field.

That DNS entry is gone now. Make sure it only says “bounce”

Above is what currently shows in my dns manager. To get that I deleted the previous entry and reentered the full “bounce.omnistrat.com”. I didn’t do this right now, I did this before when I got the message to reenter when I was trying to validate on Stripe’s end.

So it now says “bounce”, but Stripe isn’t validating this. Should I reenter again, but just type in “bounce”?

It looks right. That’s frustrating, as it was resolving before. Just with the wrong CNAME destination.

It looks like that’s what you already did.

If you don’t mind a little digging, can you Export your DNS records and comb through the file to look for that CNAME?

OK, I found the reason. There are multiple instances of “custom-email-domain” in the other cname records that I didn’t pick up. Not sure why Stripe gave me an all clear. I’ll update them and I should be good.

Holly-molly. I now have all seven cname records failing and telling me to reenter. What is going on?

Last time I chatted on an issue I was having the chat was abruptly ended because I exceeded the limit of posts as a new community member. I didn’t get any warning, so just wanted to thank you for your help now in case I get cut off again. Thanks!!

Ok, here is what I think the issue may be: Stripe’s record is “custom-email-domain.stripe.com”. I’ve changed it to “omnistrat.stripe.com”. Maybe I should just use “omnistrat.com”? What do you think?

Nope. It still needs to point to something that ends in stripe.com

I’m just not seeing that DNS record any more. Did you have any luck Exporting those DNS records?

If I’m exposing sensitive info, please let me know so I can delete after you review.

Go ahead and delete that post.

I see that the CNAME is there, and it shows up in dnschecker.org.

At this point, I believe you’ll need to work this out with Stripe.

Thanks for your help. The Stripe chat support person had to escalate this, so maybe there is a bug/problem.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.