URIs of our articles are having cdn-4 prefix

Hello everyone.

Recently I’ve noticed that some of our articles received the cdn-4 prefix in front of the URI when showing in Google results. For example, this is the original article: Global Error Handling in ASP.NET Core Web API - Code Maze , but when you find it on Google:


It is easy to see a different address. Also, once I click the link, it doesn’t navigate me to the original URI but to the one shown in the picture: https://cdn-4.code-maze.com/global-error-handling-aspnetcore/

Now the comments are spread across the articles, which is bad for the readers.

Does anyone know why would this happen?

Just to say, that I am not that familiar with CDN caching, and obviously, I didn’t configure it for our site, my colleague did. We are using WordPress to host the site.

If there is any suggestion you could give us, I would appreciate it a lot.

Thank you very much and all the best.

You have configured (or imported) a “cdn-4” record in your DNS settings and generate such links somewhere on your website (or possibly also somewhere else) and that’s why Google follows and indexes them.

You should remove all DNS records you don’t want and make sure the generated links are correct. You can probably also use the Google dashboard to remove these entries, but that’s not really a Cloudflare question at this point I am afraid.

Thank you very much for the response.

We’ll try to do that and see if it helps.

One more time, thanks a lot for the help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.