Urgent! Please Help

I Have changed my DNS to Cloudflare.

The main domain is working fine, but the subdomain is showing the error DNS_PROBE_FINISHED_NXDOMAIN.
please help! in loss of my business.


Kindly please help!

Thank you

May I ask if you have an CNAME or A record for your sub-domain study.piacademy.co.uk?
Also, is the DNS record for that sub-domain :orange: or :grey: cloud?

Moreover, what SSL option have you got selected at Cloudflare dashboard? (Flexible SSL, Full SSL …)

Have you had an SSL certificate already installed at your host/origin server?
If yes, does the SSL certificate cover your sub-domain hostname?

Here are the steps regarding the DNS_PROBE_FINISHED_NXDOMAIN:

Moreover, as tested, I got 521 error.
Have you tried looking for a fix here?
Kindly, follow the steps in the article and the post from below to solve your issue:


I have selected A record for the subdomain, and is yellow colour (: orange:)

SSL option setup is Full

Main Domain has already SSL Installed.
But it is not covering the subdomain.

Your SSL certificate should cover your sub-domain too.

Make the A study record :grey:, then if you for example used an Let's Encrypt or cPanel’s AutoSSL, you can generate an SSL certificate for your sub-domain too.

After generating and if you can access your study.piacademy.co.uk via HTTPS, then all good, turn the :grey: back to :orange: cloud to make sure Full SSL mode is working propperly.

Other solution would be either to purchase an SSL certificate from one of the resellers like NameCheap, Comodo, etc. for your main domain and other sub-domain(s) and install it at your host/origin server. Then, activating Full SSL mode at Cloudflare.

Or, purchasing a Dedicated SSL certificate using Cloudflare Advanced Certificate Manager.

Or, another option would be to use Cloudflare CA Origin certificate, which you can generate at Cloudflare dashboard for needed hostnames (main domain, sub-domains) and then upload/install it at your host/origin and also turn on the Full SSL mode.

Just to note, in case you would use Cloudflare CA origin certificate cannot be used for exmaple mail.yourdomain.com, as the Cloudflare neither doesn’t proxy the e-mail traffic.

Another one option, but really not recommended is to make a Page Rule for your study.piacademy.co.uk to have Flexible SSL temporarly. But, again, not recommended option due to the article below:

If you already have an SSL certificate that covers your domain and sub-domain(s) and would like to use it, there is an option to upload it to Cloudflare via dashboard, but that option is available only to a Business or an Enterprise paid plan:


I just made the change to grey color, it is now giving ERR_CONNECTION_REFUSED

Please help!

Now I can load your sub-domain over HTTP (as we wanted to test if the web server is responding correctly without an SSL certificate) and not being proxied via Cloudflare (:orange:) with HTTPS connection which requires you to have a SSL certificate for your sub-domain, for which one the current SSL certificate you have does not cover the wanted sub-domain.

1 Like

I used Lets Encrypt to create the SSL certificate for main Domain name,
please help how to do that for subdomain as well?
I am really worried now.


Well, you obviously do not remember what steps have you made to get it, right?

1 Like

yes @fritexvz

It was very long time ago, the cerificate I created when my hosting was in digitalocean with command line tool.
one year ago I changed my main domain hosting to cloudways,
however subdomain hosting is still in digitalocean as I run different app for children to study over subdomain.

I have installed the ssl certificate on the sub domain digitalocean server, now getting the error: ERR_TOO_MANY_REDIRECTS

installed by following these steps.

please help!

Here is an tutorial, possible via certbot or via acme:

This could help with this error:

After you installed the SSL certificate, have you tried turning back the :grey: to :orange: for your sub-domain?

Moreover, do you have Always use HTTPS and Automatic HTTPS redirection options both enabled at Cloudflare dashboard under SSL settings (tab)?

After all these settings, I can get it open the site, however it is showing still not secure site.

please help!

1 Like

I see it is working now over HTTPS. That is great!

Regarding your Google Chrome warning, it could be due to some mixed-content like CSS or JS files or images being loaded as over an HTTP connection on your HTTPS sub-domain?

Have you tried openning your sub-domain in another Web browser, or using a Private Window? Or clearing your Web browser cache? Would that make any difference?

1 Like

thanks i have now resolved.

1 Like

I am happy to assist you and I am glad you have found a solution to your issue :wink:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.