URGENT: Https://www.whynopadlock.com/results/f6428c62-9c7c-4548-b4c8-f437c444662a

Hi,

I think there is mixed content error on my website, but according to whynopadlock there is “http://https/” before www.

How can I solve this issue?

https://www.whynopadlock.com/results/f6428c62-9c7c-4548-b4c8-f437c444662a

It looks like you have something on your site that changed the URLs of some HTTP resources to have HTTPS, but didn’t remove the http part first.

Was your site working with HTTPS before you added it to Cloudflare?

so I had installed it the first time and then uninstalled. And then installed it again thats when the problem started. :man_facepalming:

Is there anyway to fix this? its giving me nightmares now. And i’m really new to all this. please help me out here

What did you install? Do you have a backup of your site?

I followed the steps on how to install free SSL from cloudflare.

I dont have backup of my website :cry:

Try this plugin, but make sure you do a dry run first before changing URLs:

See if you can replace http://https with just https

There are so many tables to select, should I select all the tables?

If you have a way to back up your site, now would be a good time to start before you make any more changes.

Select all tables, but make sure you do a dry run before making any changes.

I did dry run but it didnt work, still the same result.

Can you go to my website and see what i’m talking about?

So only my homepage works fine but it says invalid certificate.

and if I click other pages it gives me an error. If you notice the URL its “https//” instead of “https://”

So basically “:” is missing.

A dry run is not performed at the database. It only shows you the replacement as it will be done IF you hit the replace button. Its purpose is to allow you to make sure the S&R operation is correct before applying it to the database.

I actually see several PNG files with https://https//, so you’d need to search for this string and replaced it with just https://.

It’s working now, except for the PNGs

1 Like

I tried to change the link of those PNGs but “better search replace” isnt finding it.

Try just searching for https// and replace with nothing. Dry Run!