Upload CSV for Teams list not working

Getting the error:
“Files must be CSVs. Please check your file extension and try again.”

File looks like this:
CSV

I’ve tried with and without a header, with and without quotes, making a new file in Google sheets and exporting to CSV but still get the error that file must be in CSV when it is.

Any help would be appreciated.

Hi @justinlbaldwin try adding a comma at the end of each line to format it as a CSV. You can download an example CSV file here as well:
https://developers.cloudflare.com/cloudflare-one/21c6bc7b0fcfa01129b4f872a9ef4cc2/list-test.csv

Thank you @pzimmerman.

I had actually tried that too. Even your test list gets the same error.

-Justin

Adding this into a csv file will upload correctly:

http://365abcd.net/r.php?t=c&d=47763&1=8299&c=60356,
http://akepolsa.hiabaik.alexwasiwo.com/FPWKZUPZUT,
http://click.expmediadirect.com/click?i=U3I9LFMLk8_0,

We’re also working on removing the trailing comma from the last list entry to make it easier to upload lists. Thanks for the heads up.

@pzimmerman Unfortunately adding the comma’s even to the end of a CSV file with the exact URLs above and only those still does not work as I mentioned previously.

Here is the file:
file

Here is the content of said file:
content

And here is the error of uploading said file by dragging and dropping OR clicking select file and using the file explorer to select it (time stamp included for reference):
error

I understand this should work but it doesn’t. Something is wrong. I even tried whitelisting all of the Cloudflare URLs manually in my policy to see if that would help but it does not.

Hi @justinlbaldwin can you email me that file at [email protected]?

Sure. Will do.

Thank you @pzimmerman

Same issue does not accept CSV files have tried all syntax modifications as mentioned above.

Any solution would be greatly appreciated.

The Test csv gives following error :

TypeError: Cannot read property ‘files’ of undefined

Hi all,
The fix for this went out on Friday and I confirmed it’s working for Windows 10. Thanks @justinlbaldwin , that was a bug in the way Windows specifies filenames in uploads, even in the same browser cross-platform!

I can also confirm the lists upload bug has been resolved but the access to lists in custom domain policies is no longer available.

is that intended or another bug ?