“Updating failed. The response is not a valid JSON response”


I get this error, when I add some specific words in my wordpress posts.

> Updating failed. The response is not a valid JSON response.

For example, I added the following words in my Wordpress post:


If I turned off the WAF completely in my Cloudflare dashboard, I can able to add those words again. Anyone have any clue to fix this? I don’t want to completely turn OFF WAF.

I contacted the hosting provider. They said nothing is blocking on their side.
I disabled my security plugin and tried again. But the I keep getting the same error.

Strangely, I don’t have this issue in Classic editor. I only facing this error on Gutenberg editor. I would be grateful if someone give me any clue.

Same issue as Cloudlfare confusing orange message - #2 by domjh with the same answer :slight_smile:

Hi Sandro,

Do you have any clue? I followed several tutorials on this topic and none of them helped to fix this issue. The only way is to completely disable WAF in Cloudflare dashboard.

Well, as suggested in the posting, what did the event log say?

Hi Sandro,

I am using All-in-one WP security firewall. All In One WP Security & Firewall – WordPress plugin | WordPress.org

I don’t know where to look for the Event logs. I don’t see it in my firewall settings.

Cloudflare’s firewall, on the security screen.

Hi Sandro,

You mean this one?

Seems like it, you can either disable that particular rule or whitelist your IP address or network.

Hi Sandro,

I found the rule and disabled it. But it is keep getting enabled automatically. I also whitelisted my origin server’s IP address under “IP Access rules” section.

That’s the right rule, it shouldn’t re-activate however. Maybe also check your audit log.

As for the IP access rule, that’s right, though you need to whiteliste your own IP address, not your server’s.

Ok. But mine is dynamic IP and is changing every day.

and where is the audit log?

In that case you could whitelist your ISP via its ASN.

I whitelisted the ASN. But I can’t disable the rule. It is keep getting enabled automatically. Is there any other way?

Well, if you whitelisted the ASN, you don’t need to disable the rule.

It is solved. Thank you very much Sandro.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.