Update ddns ipaddress by using ddclient but 301 received always

dns

#1

Hello,

I used ddclient on my raspberry pi to update cloudflare dns record. However, I always get 301 http response code from server.

SENDING:  GET /zones?name=********* HTTP/1.0
SENDING:   Host: www.cloudflare.com
SENDING:   User-Agent: ddclient/3.9.0
SENDING:   Connection: close
SENDING:   X-Auth-Email: ******@gmail.com
SENDING:   X-Auth-Key: **************
SENDING:   Content-Type: application/json
SENDING:   
RECEIVE:  HTTP/1.1 301 Moved Permanently
RECEIVE:  Date: Sun, 19 Aug 2018 09:20:51 GMT
RECEIVE:  Content-Type: text/html
RECEIVE:  Connection: close
RECEIVE:  Set-Cookie: __cfduid=dd8be7008c22ac9938eb43d5908c95c6c1534670451; expires=Mon, 19-Aug-19 09:20:51 GMT; path=/; domain=.cloudflare.com; HttpOnly
RECEIVE:  Location: https://www.cloudflare.com/zones/?name=*****.net
RECEIVE:  X-XSS-Protection: 1; mode=block
RECEIVE:  Strict-Transport-Security: max-age=15780000; includeSubDomains
RECEIVE:  X-Content-Type-Options: nosniff
RECEIVE:  X-Frame-Options: SAMEORIGIN
RECEIVE:  Served-In-Seconds: 0.001
RECEIVE:  Set-Cookie: __cflb=1594113181; path=/; expires=Mon, 20-Aug-18 08:20:51 GMT
RECEIVE:  Expect-CT: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
RECEIVE:  Server: cloudflare
RECEIVE:  CF-RAY: 44cb8bf38df24554-TPE
RECEIVE:  
RECEIVE:  <html>
RECEIVE:  <head><title>301 Moved Permanently</title></head>
RECEIVE:  <body bgcolor="white">
RECEIVE:  <center><h1>301 Moved Permanently</h1></center>
RECEIVE:  <hr><center>nginx/1.10.3</center>
RECEIVE:  </body>
RECEIVE:  </html>

Here is my setting

##
## Cloudflare (cloudflare.com)
##

#How offten to check ip address
daemon=1800

#Using cloudflare protocol
protocol=cloudflare 

#Tell ddclient to get real ip address
use=web, web=ip.changeip.com

#Credentials for cloudflare api
ssl=yes
server=www.cloudflare.com
login=********@gmail.com
password=**********
zone=******.net

#Domain for update
arm.******.net

#2

If you are using ddclient, the server url should be updated as…

api.cloudflare.com/client/v4

#Credentials for cloudflare api
ssl=yes
server=api.cloudflare.com/client/v4


#3