Update CF plugin wordpress

I get the following error - “symfony/polyfill-php70 bootstrap php failed to open stream: no such file or directory” after updating CF plugin ver 4.5.0 this morning - had to disable plugin complete to get site back online

please file an issue here: https://github.com/cloudflare/Cloudflare-WordPress/issues/new/choose
There were reports of CF plugin 4.5.0 with PHP 8 errors, please not we don’t support PHP 8 officially as of yet.

We’ve had the same issue. You can downgrade or fix it. To fix, download the missing file from here:

And put this file (bootstrap80.php) in the folder /wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer

After this, the plugin should work again! If not, check your error message to find out what file is missing and find it from the Symfony repo mentioned above yourself!

1 Like

Same here. Where can I find 4.4, in order to downgrade?

Documentation says “Make sure your PHP version is 7.2 or higher.” Please update if that is not the case. PHP 8 is becoming the new standard.

Can you please share a link to find Cloudflare 4.4? I cannot find it anywhere?

sure: https://downloads.wordpress.org/plugin/cloudflare.4.4.0.zip

1 Like

same erorr

Warning : require(/home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap80.php): Failed to open stream: No such file or directory in /home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap.php on line 15

Fatal error : Uncaught Error: Failed opening required ‘/home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap80.php’ (include_path=’.:’) in /home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap.php:15 Stack trace: #0 /home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php(69): require() #1 /home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/composer/autoload_real.php(59): composerRequire386a6fce91e17b37d63cb251597d5bd5() #2 /home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/autoload.php(7): ComposerAutoloaderInit386a6fce91e17b37d63cb251597d5bd5::getLoader() #3 /home/daneloo/public_html/wp-content/plugins/cloudflare/cloudflare.loader.php(3): require_once(’…’) #4 /home/daneloo/public_html/wp-content/plugins/cloudflare/cloudflare.php(49): require_once(’…’) #5 /home/daneloo/public_html/wp-admin/includes/plugin.php(2300): include(’…’) #6 /home/daneloo/public_html/wp-admin/plugins.php(191): plugin_sandbox_scrape() #7 {main} thrown in /home/daneloo/public_html/wp-content/plugins/cloudflare/vendor/symfony/polyfill-intl-normalizer/bootstrap.php on line 15

reverting to 4.4 fixed post admin error for me. Can now edit and save posts.

i need link to download 4.4

4.4.0 works with PHP 8.0 for me. So thanks for giving us this version in this thread. When do you have an ETA for full PHP 8.0 support in 4.5.0, since 4.4.0 seems to work just fine? :slight_smile:

1 Like

Good news, the latest version 4.5.1 should be PHP 7 compatible: https://downloads.wordpress.org/plugin/cloudflare.4.5.1.zip
The change log: Release v4.5.1 (2021-06-03) · cloudflare/Cloudflare-WordPress · GitHub

1 Like

Updated on mine but same error. reverted and fine. I suppose cache could have been a problem but don’t think so

https://downloads.wordpress.org/plugin/cloudflare.4.4.0.zip

For reference Yevgen – Apache/2.2.15 (CentOS) , PHP 7.3.25, MySQL version: 5.6.41-log

yes, seems like 4.5.0 was causing problems even on PHP 7, so 4.5.1 should make it compatible with PHP 7 but not PHP 8. Please report a bug: https://github.com/cloudflare/Cloudflare-WordPress/issues/new/choose if 4.5.1 causes issues with PHP 7.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.