Unsecured Web Page SSL

Hi. I used to host my wordpress website in my basement until due to running costs I moved it to paid hosting. The first hosting company I used was calle hostinguk and I found them to be pretty ■■■■ so i moved back to my older hosting company called TSOHost. I migrated the website over using a plugin and it was seemelss. I then changed the name servers from TSOHost to Cloudflare and setup the DNS records in Cloudflare dashboard. SO on mobile phone the website is secured with SSL, I have even asked family and friends from around the world to test the site out and they all say its secure on ,mobile, desktop, PC, MAC, laptop etc however on my laptop it is saying http not secure and the page loads into plesk control panel from the “■■■■” hostinguk service provider on both chrome and edge browser.

Is thre something else I should be doing here? I have tried to clear wordpress cache, i’ve cleared internet history and cache on laptop.

Thanks,. Craig.

Sounds like the IP address in your local network is still resolving to your old host.

Do a ping to your website and check to see that it resolves to the right address. If it still resolves to the old address then troubleshoot why that is (could be one of several reasons why, including your local router holding the old value in cache, so reboot the router to clear).

1 Like

Are you using Full (Strict) and only Full (Strict)?

If you are suing any other mode, you are not getting the best security, and should change your SSL/TLS to Full (Strict)

Hello, thanks for your replies. I have restarted my router but the problem still persists. The problem is I can’t get into wp-admin to edit my website. I’m not sure weather to wipe the website and start again but seems a bit extreme considering it works on mobile device and everyones PC but mine. Any other suggestions ?

Thanks.

I did a ping on the address but it gives I presume a Cloudflare ip address.

Thanks.

Hello @ethandavo ,

Did you try flushing DNS cache from your pc?

What IP address does it give you when you ping the site?

Hi, yes I tried from cmd prompt, came back successful. Do you think trying in safe mode as the problem is still present.

Thanks.

172.67.157.10

That is indeed a Cloudflare IP, so it doesn’t really make sense why that device can’t browse properly but other devices can.

One other thing to check if you’re getting certificate errors just on one device is to make sure the date/time is correct on the device.

Good luck finding the source of the problem.

Will double check the date and time. If I wiped the laptop would that help? Also can’t understand why the MAC also has this problem.

Thanks.

@ethandavo
What’s the website?

360n dot co dot uk I’m not allowed to post links.

It loads perfect on mobile on my home network and people I’ve asked to check the link on fb say its working fine. This is why I’m so frustrated.

Thanks.

Is it the one?

Yes that’s the one.

Is that the way its supposed to load? What you get instead? Would you drop the shot?

That’s what I get too. There are a few errors on the page if you look in the dev tools, and there’s a mixture of secure and insecure objects on the page (some images are not loading https). But at least on my browser it seems fine.

I wonder if the Op previously had hsts on their website certificate and their browser has cached that. If that’s what’s causing the issue then clear hsts for the site using the instructions below:

I can’t post pics… Will try and put an image on a site and post a link.

Thanks.

When I do the query for HSTS I get not found…

@ethandavo
A couple of checks you may need to run:
Check this #CommunityTip

Try clearing the cache file from Cloudflare as well.
I also observed that your site is missing the CAA records. I suggest you to check the records first. If you have a misconfiguration, your site may not load as expected.