Unsecure SSL- Certificate mismatch

Hello,

I’d really appreciate any help you can provide here. I’m currently transferring a domain from Wix - Google. During this time, I pointed the domain’s A record towards my staging domain, as when wix transfers it’s website will be unavailable.

This works over http, it points to my staging domain, which then redirects back to the wix template.

My problem is that SSL is no longer available, and displays the no certificate error page when accessing via https://. (certificate mismatch when i look into it more closely)

How does this involve cloudflare? My staging domain is connected to cloudflare (with SSL) via NS which points to my server IP. Is there anything I can do to resolve this? I cannot update DNS for the domain during the transfer.

Staging domain:


Real Domain:
*Removed after answer solved.

thank you so much

Hi, this domain isn’t using Cloudflare’s nameservers and consequently none of its features.

It doesn’t.

You could configure a valid certificate for that domain.

1 Like

@raphaelarocha Thank you for your response. So I’m realising that i’m pointing directly to the A record of the server, therefore missing out on cloudflare.

It had a valid certificate, but since initiating the domain transfer it is lost, and I do not have access to the DNS for the domain anymore while this is ongoing. Are there any other options available?

*edit- a word

You could still configure a valid certificate on the server that responds to sunshine-residences.com requests. Couldn’t you?

1 Like

@raphaelarocha I have access to the server where I am pointing the sunshine-residences domain to via A record. Therefore I could configure SSL to the acemsweb domain directly. Is this what you mean?

I am unable to make any adjustments in the origin, i.e. the wix platform where sunshine-residences domain is currently sitting.

Thanks in advance

1 Like

Exactly. The wix website seems to be ok for now. The certificate problem only happens on the sunshine-residences, so if you configure a valid certificate there it should work fine.

1 Like

Thanks for your answer. Since I can’t update the domain. I will try adding SSL to the acemsweb domain directly, and hope that the pointing from sunshine-res directly to the A record on the server is then secure.

Just to be clear, you would still not be using Cloudflare’s features.
Configuring the certificate would only fix the error you are getting when trying to access the address through HTTPS.

To use Cloudflare you would still need to add the website to Cloudflare and change the Nameservers, which are, at the moment, still pointing to WIX’s NS.

sunshine-residences.com. 86400  IN      NS      ns2.wixdns.net.
sunshine-residences.com. 86400  IN      NS      ns3.wixdns.net.
1 Like

I understand, Wix doesn’t allow me to change the NS (that’s why i’m actually transferring it). Now I cannot even access the DNS for sunshine-res domain.

At the moment, the key is fixing the https, so I will try your advice to add SSL to the server for acemsweb where I am pointing sunshine-res domain via A record.

@raphaelarocha Thank you for help. SSL installed on the server which it resolves to, and it works! :grinning: