Universal SSL's validation status is still pending

Hello!

My Universal SSL’s validation status is still pending. I already changed the nameservers three hours ago.

I bought the domain from Hostinger.


However, my Universal SSL’s validation status is still pending

I already installed an Origin Certificate to the server, but no luck in securing the domain to HTTPS.

I tried to check the host via https://check-host.net/, and here are the results of my domain.

Note: The covered IP address is my origin server. I turned off the proxy for a while to check if the validation status of my Universal SSL would change. Still no luck.

I know that I need to wait for 24-48 hours to finish the propagation, but the domains that I bought from GoDaddy before were really fast to propagate. It only took a minute to work.

How to solve the issue? I already sent an email to Hostinger Support, still waiting for their feedback.

This is certainly evident from your DNS check, and may be the issue.

Here’s general information on issuing certificates:

Hello, @sdayman

Thank you for the feedback. I already solved it.

I saw that the DNSSEC and Bot Fight Mode were enabled by default.

I do have clear evidence of whether the Firewall made it so hard to propagate my domain 'cause my Analytics indicated that it already blocked 13.92k requests from bots.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.