Universal SSL, switching to let's encrypt not working


Due to TLD blacklist from digicert, I’ve switched universal SSL to let’s encrypt certificate using API call.
18 hours has gone and let’s encrypt certificated is still in pending state.

How much time it usually takes to issue LE certificate through Cloudflare universal SSL service?

Ticket #2502785 (I’m on business plan)
Unfortunately support guys can’t help me in a timed manner :frowning: 3 days have gone I’ve requested help through Cloudflare ticket system and still no help/answer.

Please help.

Hi again @maxim1,

I’m sorry to hear this issue is still not resolved, it should not take that long to issue the certificate.

If the domain on a Full DNS setup with Cloudflare or on a CNAME or partial setup? Is there any kind of indication of the specific issue under Edge Certificates if you hover over the Pending message?

1 Like

Full DNS setup.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.