Universal SSL Status

Hello Community,
Hope all of you are doing very well.

I’m using the free Let’s Encrypt SSL for my domain Look.ir
The problem that I have in my Cloudflare panel on SSL/TLS app is Universal SSL Status which is on Certificate Pending Validation and is not getting activated like my another domain which is on the same hosting provider and same panel as an addon domain.

The other domain which is working fine is: ParsLady.ir

I’ve got confused for the reason that the ssl for Look.ir has pending status however it’s fully configured same as ParsLady.ir
Same host, same panel, same free ssl (Let’s Encrypt)

I have paused Cloudflare currently on Look.ir to avoid making down the site.

If you have any experience on this, I will appreciate your share and help.

Kind regards,

That’s odd, I have similar problem.

1 Like

Check this out first and definitely try disabling Universal SSL, waiting and then re-enabling it to restart the process.

1 Like

I have done all these steps, checked a tons of articles and finally decided to open a support topic which then I saw someone has exactly the same problem as I do.

Can a server’s IP address get blocked by Cloudflare? Because I have a few accounts on this server they all have the same problem. Cloudflare IPs are whitelisted in CSF too.

1 Like

What about the answer to the questions in the post I linked to?

I doubt it is due to the IP of the server.

1 Like

Hi @domjh
Hope you are fine.

Now I am waiting for 3days and still pending.
I tried to reply the topic you sent its link, but it was closed.

What should I do now?

I have contacted the support too but still no reply from them.


Hi @RahimVaziri,

Both sites load with the certificates in place. Try clearing cache, try from an incognito window, or try a different browser.

For future reference, here’s a good tip on the cipher mismatch error

1 Like

Hi @cloonan

This is Look.ir:

And this is ParsLady.ir:

As you can see the Look.ir is has pending status over 3days, so I had to pause Cloudflare on Look.ir but ParsLady.ir is working fine.

Dear @cloonan

I have made a ticket on your support area and still waiting for your help.
Ticket Number: 1685029


Thank you, @RahimVaziri, I’ve noted that on your ticket. Can you do the following on look.ir?

  • Go to SSL/TLS app on your Cloudflare dashboard and scroll down to the bottom
  • Click the Disable Universal SSL
  • Wait for a few minutes then click the Enable Universal SSL
1 Like

Dear @cloonan,

I have done this more than 20times during these days, but for sure, now I will do it again and will share the result with you.

ah, got it, thank you. @domjh nailed it on another thread, pretty sure it’s the .ir zone that is causing issues. CIPHER MISMATCH issue

1 Like

Dear @cloonan

Shall I delete the Origin Certificates before Enabling Universal SSL?

Yeah, you are right.
But as you see it got immediately active for my other .ir domain: parslady.ir
I don’t know why this is happening only on this domain.
I see some other .ir domains are using your service: https://iwushu.ir

1 Like

Those are unrelated. Keep them without issues.

1 Like

OK, let’s keep trying then. As @matteo mentioned, leave the other cert in place, it’s necessary.

Can you unpause Cloudflare and turn on development mode? On the overview tab, the option is on the right sidebar. After that, try the toggle on off on the universal ssl on the SSL/TLS app.


Ok. I did exactly what you said @cloonan.

Still the same status and result.

And if you check my site: Look.ir , you will see it got down.

is development mode enabled?

1 Like

sorry @cloonan just enabled that.

1 Like