Universal SSL Status stuck at "Authorizing Certificate"

It’s been more than 3 days and the status still didn’t completed, now when I access my website using https, chrome says “ERR_SSL_VERSION_OR_CIPHER_MISMATCH”.

Thanks everyone.

And your site is?

If it is still authorizing please read this:

Try going to the bottom of that Crypto page and clicking “Disable Universal SSL”

Then wait 10 or so minutes and then click “Enable Universal SSL”

If that doesn’t work, try @MarkMeyer’s suggestion (that he posted while I’m typing this).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.