Universal SSL pending for multiple days

I tried adding cloudflare to my server and it has been giving me this error: “SSL_ERROR_NO_CYPHER_OVERLAP” in firefox and “ERR_SSL_VERSION_OR_CIPHER_MISMATCH” in chrome.

Universal SSL has been pending for multiple days (I changed server config and still nothing happened. It was pending before I tried again for over 2 days).

I do not really know what to do about this, as this has never happened to me before.

I am serving my website with nginx on ubuntu.

This weirds me out because I have hosted a similar server before without this issue.


For reference, this is not using a subdomain, but the root domain.

What’s the domain?

Have you made any settings changes, such as Firewall?


The domain is perhaps [dot] bio.

I have not made any changes to firewall.

DNSSEC is broken, so SSL can’t validate your domain.



Best shut it off at Porkbun, and in Cloudflare DNS for now.




Ok :slight_smile:

I disabled DNSSEC at both prokbun and in cloudflare.

Will update when its finished removing.

OK I think I fixed it, now I have a server issue but this is progress :slight_smile:

I checked dnsviz and the error is gone.

Thank you very much for the help, I really appreciate it.


A post was split to a new topic: Help me configuring SSL on my website