Universal ssl is deleted

i pointed my domain namesever to cloudfalre already and im using plesk cloudflare pro.

im not sure if my dns is ok

in universal ssl is showing my root domain is deleted but other sub domains are alright.

i opened a support ticket but it took hours and still not replied yet.

Is your domain listed as active on Cloudflare?

What is the domain?

yes it is active, my domain is macoscrack.com, i pasued my website on cloudflare at the moment coz it shows ssl error and the universal ssl is showing deleted.

Can you post a full page screenshot of https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates?




Strangely you only have a certificate for www. I’d disable Universal SSL for now (very bottom), wait about an hour, and then re-enable it. Then check if the certificate is issued.

well i tried, and still the same.

You tried what?

disable it and enable it

Well, considering that I had written that only a couple of minutes ago you can’t have waited an hour.

i meant before i created this topic

Well, it would be good to provide more than one-liners when it comes to information :wink:

And then you waited for an hour before enabling it?

Have you ever been on a CNAME setup?

1 Like

i thought that was a problem too, so i even changed my nameserver tp cloudflare and still not working. since godaddy wont let root domain to have a @ cname record

Again

Another thing you can try is switching the certificate authority. That might just fix it. For that use the undocumented certificate_authority field of the Cloudflare API v4 Documentation call and switch the authority yourself, which should also re-issue the certificate.

curl -X PATCH "https://api.cloudflare.com/client/v4/zones/[zone_id]/ssl/universal/settings" \
     -H "Content-Type: application/json" \
     -H "X-Auth-Email: [YOUR-EMAIL-ADDRESS]" \
     -H "X-Auth-Key: [YOUR-GLOBAL-API-KEY]" \
     --data '{"certificate_authority": "digicert"}'

i will try it tomorrow, some articles say cloudflare is issuing the ssl, it may take 24 hours

i saw some people fixing the issue through this, but after i read the article, i have no idea how to do it…

You are running curl and run the given command with correct parameters as explained by the documentation.

Or any other HTTP client where you can run that request of course.