Universal SSL Edge Certificate not created after

Hello

The Universal SSL Edge Certificates won’t be generated for my domain ir-adviser.com hence, when I activate the proxy for my domain in the DNS Management and try to access my website, the web browser presents these errror messages (varies from browser to browser):
SSL_ERROR_NO_CYPHER_OVERLAP
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

In order to facilitate information to receive help more efficiently, I present the following requested information below.

What is the domain name?
ir-adviser.com

Have you searched for an answer?
Yes. I have found many posts with the same problem like me, but I’m noticing that in my case I don’t get a Pending Status message in the Edge Certificates section, just a message that reads “No certificates”, no matter how many times I repeat the procedure for Universal SSL certificate generation.

Please share your search results url:

https://developers.cloudflare.com/ssl/edge-certificates/universal-ssl/enable-universal-ssl/
https://community.cloudflare.com/t/community-tip-best-practices-for-certificate-provisioning/44230
https://community.cloudflare.com/t/community-tip-fixing-err-ssl-version-or-cipher-mismatch-in-google-chrome/42162

I’ve followed all the steps of the procedures described in the above pages and many other posts of similar problems that has been resolved.

When you tested your domain, what were the results?

Describe the issue you are having:
Universal SSL Edge Certificates are not generated.
It has been more than 24h after added my domain to Cloudflare.
I’ve followed the procedures described in the previous URLs but I don’t get the certificates to appear int the Edge Certificates section.
When I enable the proxy on my root domain ( zone apex) in the DNS Management, the web browser (Chrome) presents this error message: ERR_SSL_VERSION_OR_CIPHER_MISMATCH. I have to deactivate the proxy in order to access my web site using the origin’s SSL Certificate and that’s the only way I can access my web site.

What steps have you taken to resolve the issue?

  1. Grey-cloud/deactivate Cloudflare so that the website uses the origin’s SSL certificate
  2. Disabled Universal SSL
  3. Waited for a few minutes (I have waited up to 30 minutes)
  4. Enabled Universal SSL.
  5. Waited up to 24h

Was the site working with SSL prior to adding it to Cloudflare?
Yes

What are the steps to reproduce the error:

  1. Enable proxy for my domain (ir-adviser.com) at DNS Management
  2. Open https://ir-adviser.com or https://www.ir-adviser.com in web browser
  3. Site cannot be opened and web browser shows error message: ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Have you tried from another browser and/or incognito mode?
Yes, Chrome, Edge, Firefox and Brave

Please attach a screenshot of the error:

Hope there’s someone who can help me.

Sorry you have been dealing with this on your site. I made a couple of changes on the back end and it appears to be working now.

This seems to be related to a previous issue with the site that we solved.

Let us know if you have any problems still.

1 Like

I’t working now.

Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.