Universal SSL certificate has been showing "Pending Validation Error" for more than 48 hours

It’s been more than 48hrs waiting for Universal SSL certificate to validate on my domain office.co.zw . I’m getting Pending Validation (Error) message.
I’ve tried recommendations in the other requests e.g. disabling SSL and leaving it for 15min or more before enabling it again. I’ve tried deleting the certificate and starting afresh. Still I’m not getting any joy.

If you’ve followed all the instructions, they also mention that if it doesn’t work that you should open a ticket.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Yes. I’ve created a ticket. My ticket number is
#2158983

1 Like

Still need @MoreHelp my ticket #2158983

Hi, @simon48 the reply you received from Support is correct & accurate, you need to submit proof that you are allowed to use this trademark that is in your domain name. Our SSL provider will not issue the certificate without this information. This is not proof of domain ownership, rather it is proof that you have permission to use the registered trademark in the name.

3 Likes

Thanks. I didn’t realize it’s a trademark.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.