Universal SSL activation stalled?

Hi - our site is hosted with wpengine where we already have ssl set up. WPE recommends waiting until Universal SSL is active on Cloudflare before changing nameservers on domain registrar to avoid SSL problems.
We ran Cloudflares

We enabled Universal SSL on Cloudflare, but even after 3 days SSL status does not show any status.

We also tried purchasing an SSL from Cloudflare, but the validation check returned a FAILED status, so we are unable to purchase SSL either.

Please advise on what steps to take to fix issue.

I think that I may have solved this based on a prior support thread. It looks like we enabled universal ssl, and then changed the ssl setting to full (strict), which seemed to have broken the ssl request.
To solve it, we scrolled to the bottom of the Crypto page, diabled Universal ssl and then waited a few hours. Cleared the cache and with the ssl setting set to full (strict), then enabled Universal ssl again.
This time we received the “Authorizing Certificate” message. So it looks like you have to set the ssl settings first before enabling the Universal ssl request.

Hi @sleepwell, um, not changing the name servers does not seem the proper route, I am not familiar with wpengine, but typically, if you’re going to have Cloudflare name servers, you make that change first. If you’re on a partial setup, you don’t change the name servers. I don’t know of a use case between the two where you’d delay making the change. Reason being, Cloudflare does not start to provision in the certificate until after the zone is active on Cloudflare, a full setup with out the correct name servers will not activate, meaning the certificate ordering process will never initiate. I suspect the validation failed due to the name servers not being set.

(With that being said, note that turning SSL off and on again is sometimes an effective way to kickstart a slow cert provisioning process and the setting of Full (strict) is perfect as you have a certificate on your origin host.)

This topic was automatically closed after 30 days. New replies are no longer allowed.