Universal SSL acme-challenge is broken

What is the domain name?
medcell[.]com[.]br

Have you searched for an answer?
Yes

Please share your search results url:
Own Cloudflare diagnostics.

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?
None (“ask community”).

Describe the issue you are having:
This domain is not working properly. When I activate the proxy for the domain, I get the ERR_SSL_VERSION_OR_CIPHER_MISMATCH message. Universal SSL verification is “pending” for more than 72 hours for acme-challenge. I use the same configuration for all my domains, and this is the only one that crashed out of nowhere!

What error message or number are you receiving?
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

What steps have you taken to resolve the issue?

  1. I’ve already tried disabling and re-enabling Universal SSL;
  2. I already tried to create the TXT record for acme-challenge manually, but it says the record already exists but I don’t see it.
  3. I’ve already tried fixing it through Cloudflare’s self-support process, which led me here.

Was the site working with SSL prior to adding it to Cloudflare?
Yes

What are the steps to reproduce the error:

  1. Just enable Cloudflare proxy for domain (for now it is disabled, so I can have access to site directly out off the proxy).

Have you tried from another browser and/or incognito mode?
Yes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.