Universal Certificate: Timed Out Validation (TXT)

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?

Yes

Please share your search results url:

When you tested your domain, what were the results?

Google Chrome shows the following:

This site can’t provide a secure connection

getdownunder.co.uk uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Hide details

Unsupported protocol

The client and server don’t support a common SSL protocol version or cipher suite.

Describe the issue you are having:

Unable to connect to website due to SSL error

What error message or number are you receiving?

See above.

What steps have you taken to resolve the issue?

  1. Disabled the Universal SSL Certiticate on the Edge Certificates page.
  2. Waited an hour
  3. Enabled The Universal SSL option

Was the site working with SSL prior to adding it to Cloudflare?

I have been told by out support team that the customer used to have DNSSEC enabled on this domain but the Registrar through whom this domain is registered have disabled that.

What are the steps to reproduce the error:

  1. Visit https://getdownunder.co.uk/

Have you tried from another browser and/or incognito mode?

Same error in Incognito mode in Chrome.

However, Firefox does not show an error and connects to the our webserver (which then redirects to a different domain).

Please attach a screenshot of the error:

Hey there, did a little a magic and all should be fine now.

If something like this happens again, you can try disabling your Universal SSL and re-enable it after 5-10 minutes.

Thank you!

1 Like

Hi Wanda,

Your help is appreciated and I can now see that the Universal Certificate has a Status of Active.

BTW I did completely disable the Universal SSL Certificate (twice) and waited over an hour before turning it back on, but that had no affect on the Status.

Thanks agin.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.