Unexpected 522 error

Hello,

Today, my website has thrown a 522 error for no apparent reason.

Earlier today (1-2 hours before) my website was completely fine, now the site throws a 522 error.

I haven’t changed my server code (Nodejs Express + HTTPS module) or changed any CloudFlare settings.

I’ve tried the following so far:

  • Rebooting the server
  • Generating a new Origin Certificate
  • Complete cache purge

Nothing seems to work.

I can access my site via the IP address (I have to put https:// infront and accept the invalid ssl bit) but not through CloudFlare (https://www.appx.ga)

Any help would be appreciated

A 522 is covered at Community Tip - Fixing Error 522: Connection timed out

Check your firewall, if it blocks Cloudflare’s IP addresses for example.

Would you feel comfortable sharing your IP address here? If not, you could run a test with it at sitemeer.com and post back the time here when you ran the test, so I can dig it out.

1 Like

It’s not my firewall.

My IP address: https://ipremoved (only https works).
Accessing my site via the IP will send a 404 Cannot Get / thats normal behaviour when accessing the site from an IP address (I use Vhosts).

Here’s the Sitemeeter results:

I am afraid your server doesnt respond on HTTPS. Your services seem to be down or run on different ports.

1 Like

Seems to work for me.

<Image showing my site works on IP address>

The server runs on port 443 but I don’t believe that’s the cause.

Running a sitemeeter test on <IP Address>:443 still fails.

Thats Chrome, right? Cant tell whether it is HTTP or broken HTTPS.

But the main point is it does not respond on HTTPS, at least to public requests, maybe the service is running and you have a firewall entry with an exception for your own IP address.

Yes, it’s Chrome and it is HTTPS.

The HTTPS certificate is the CloudFlare Origin Certificate (not a valid CA) so that might be why.

*coughcough* meer :smile:

Thats the point. A check on port 443 fails, your service is either not up or being blocked by some firewall (with an exception for your IP address). You will need to check that locally.

The certificate is not the issue. The port itself is inaccessible.

Edit: Oh you mean “thats why” regarding the “not secure”? Yes, that will be the reason. Chrome’s UI is very confusing in this regard

1 Like

I don’t see any issues with my router firewall:

But I can’t access my IP using my phone’s data.

Also, I haven’t touched my router’s settings since I set up port forwarding for my site.

Your site runs on your own network? Maybe your ISP then.

It definitely appears to be some sort of firewall or networking issue. Something blocks requests except those from your machine. If you are on the same network, you might not even go through that firewall.

I am afraid at this point it will be really classic network debugging :slight_smile:

1 Like

Thanks, I’ll investigate into what my ISP is doing again :>

Managed to fix this issue. I just spammed the Apply Firewall Rules button on my routers settings and it worked…

(I’ve also removed my IP address from the posts to protect myself)

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.