Unexpected 301 redirect for non-https request

I have everything working on my site, however I have a question about unexpected 301 redirects to my endpoint server - I’d like http requests to make it all the way to the server as well as https, so that I can handle requests there.

With the DNS record of a subdomain proxied (orange-clouded) I’m getting 301 redirects for http requests (i.e. non-https requests result in a 301 to the https version of the request url).

I have everything that I can think of DISABLED in the settings, such as Always Use HTTPS, Automatic HTTPS Rewrites, Page Rules, etc, so I can’t see what’s causing the 301 https redirect.

For example (domain name replaced)…

curl -v http://test.my-domain-here.com/
*   Trying 104.21.6.167:80...
* Connected to test.my-domain-here.com (104.21.6.167) port 80 (#0)
> GET / HTTP/1.1
> Host: test.my-domain-here.com
> User-Agent: curl/7.83.1
> Accept: */*
>
* Mark bundle as not supporting multiuse
< HTTP/1.1 301 Moved Permanently
< Date: Tue, 17 May 2022 09:31:11 GMT
< Transfer-Encoding: chunked
< Connection: keep-alive
< Cache-Control: max-age=3600
< Expires: Tue, 17 May 2022 10:31:11 GMT
< Location: https://test.my-domain-here.com/
< Report-To: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=QkDgh%2BrUSc8HQ8B%2BCBvTDNqU%2Fy4xmXDAwN2RnZkrFAZpDv%2FP6yZZ5AeI51%2BK1Fxz4r5KKfCmJm7CeZd23VCdTvtNagJIHDMAshzdta6xR07ZS%2BVCnk%2BOGRXfkjIprLWXLoQ4DnA%2FI4A%3D"}],"group":"cf-nel","max_age":604800}
< NEL: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
< Server: cloudflare
< CF-RAY: 70cb56b48a3276a7-LHR
< alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400
<
* Connection #0 to host test.my-domain-here.com left intact

Do the settings Always Use HTTPS, Automatic HTTPS Rewrites, etc, actually do anything these days?

Scratching my head to figure out what’s causing the 301 and, more to the point, how to stop it?

:thinking:

Any help much appreciated.

Sure, that’s the very idea of Always Use HTTPS, to redirect HTTP requests to HTTPS.

However, if you have disabled it, then it shouldn’t send the redirect any more of course. Are you sure you have no page rules or Workers either?

Can you post the URL?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.