Unauthorized: Record for tunnel not found

I’m trying to follow along with this tutorial: https://developers.cloudflare.com/cloudflare-one/tutorials/single-command

When I get to step 4, for some reason, I need to remove the “–name” argument from the command in order to get it to work. If I don’t, then I get the output below.

Is this an error in the tutorial? Or am I doing something wrong? The tutorial specifically says that the command is supposed to “create a Tunnel named Grafana”, which seems to be at odds with the error message I’m getting, “Record for tunnel not found”

Command: “cloudflared tunnel --hostname [redacted1] --url localhost:8000 --name grafana”

Output:
Tunnel credentials written to /Users/[redacted2]/.cloudflared/[redacted3].json. cloudflared chose this file based on where your origin certificate was found. Keep this file secret. To revoke these credentials, delete the tunnel.

Created tunnel grafana with id [redacted3]

2021-08-04T17:31:27Z ERR failed to provision routing, please create it manually via Cloudflare dashboard or UI; most likely you already have a conflicting record there. You can also rerun this command with ----overwrite-dns, -f Overwrites existing DNS records with this hostname (default: false) [$TUNNEL_FORCE_PROVISIONING_DNS] to overwrite any existing DNS records for this hostname. error=“Failed to add route: code: 1003, reason: An A, AAAA or CNAME record already exists with that host.” route=“dns [redacted1]”

2021-08-04T17:31:27Z INF Cannot determine default configuration path. No file [config.yml config.yaml] in [~/.cloudflared ~/.cloudflare-warp ~/cloudflare-warp /etc/cloudflared /usr/local/etc/cloudflared]

2021-08-04T17:31:27Z INF Version 2021.8.1

2021-08-04T17:31:27Z INF GOOS: darwin, GOVersion: go1.16.5, GoArch: amd64

2021-08-04T17:31:27Z INF Settings: map[hostname:[redacted1] n:grafana name:grafana url:localhost:8000]

2021-08-04T17:31:27Z INF cloudflared will not automatically update when run from the shell. To enable auto-updates, run cloudflared as a service: https://developers.cloudflare.com/argo-tunnel/reference/service/

2021-08-04T17:31:27Z INF Generated Connector ID: [redacted4]

2021-08-04T17:31:27Z INF Initial protocol http2

2021-08-04T17:31:27Z INF Starting metrics server on 127.0.0.1:62155/metrics

2021-08-04T17:31:28Z ERR Register tunnel error from server side error=“Unauthorized: Record for tunnel not found” connIndex=0

2021-08-04T17:31:28Z INF Retrying connection in up to 2s seconds connIndex=0

2021-08-04T17:31:29Z ERR Register tunnel error from server side error=“Unauthorized: Record for tunnel not found” connIndex=0

2021-08-04T17:31:29Z INF Retrying connection in up to 4s seconds connIndex=0

2021-08-04T17:31:31Z ERR Register tunnel error from server side error=“Unauthorized: Record for tunnel not found” connIndex=0

2021-08-04T17:31:31Z INF Retrying connection in up to 8s seconds connIndex=0

2021-08-04T17:31:31Z ERR Register tunnel error from server side error=“Unauthorized: Record for tunnel not found” connIndex=0

2021-08-04T17:31:31Z INF Retrying connection in up to 16s seconds connIndex=0

2021-08-04T17:31:43Z ERR Register tunnel error from server side error=“Unauthorized: Record for tunnel not found” connIndex=0

2021-08-04T17:31:43Z INF Retrying connection in up to 32s seconds connIndex=0

2021-08-04T17:31:58Z INF Switching to fallback protocol h2mux connIndex=0

2021-08-04T17:31:59Z ERR Register tunnel error from server side error=“Unauthorized: Record for tunnel not found” connIndex=0

2021-08-04T17:31:59Z INF Tunnel server stopped

2021-08-04T17:31:59Z ERR Initiating shutdown error=“Unauthorized: Record for tunnel not found”

2021-08-04T17:31:59Z INF Metrics server stopped

error running tunnel: Unauthorized: Record for tunnel not found

1 Like

Hi , same problem here :smiley: thought I were the only stupid guy that doesn’t get it

+1

Ah they opened an incident Cloudflare Status - Argo tunnel connection propagation delay

Correct, the problem mentioned here in this thread would have been caused by that. It got fixed shortly after you posted this comment.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.