Unable use IPv6 under CNAME

#1

Hi,
My domain has IPv6 and IPv4, also my server also.
Why I dig www.ookangzheng.com AAAA return no IPV6?
If I dig ookangzheng.com AAAA, it works perfectly.

Thanks

0 Likes

#2

You either need to unproxy that record or - depending on your setup - stop flattening non-root CNAMEs.

0 Likes

#3

This is my setting, I put CNAME www go through proxy

0 Likes

#4

You need to switch that record to :grey:

0 Likes

#5

Ya, it works. but how can I get www.ookangzheng.com AAAA using Cloudflare IPV6?

0 Likes

#6

I am not sure about your question, as I already addressed it twice. Unproxy it and stop flattening CNAMES, in case you do.

0 Likes

#7

Sorry for my bad english I dont know what does this mean.
Now everything works fine.
I deleted CNAME record, add www with A & AAAA record manually, turn on proxy yellow cloud… It works :joy:

0 Likes

#8

Right now it does return IPv6 entries but these are Cloudflare’s proxies. Is that what you want or do you want the actual IP address to show up?

0 Likes

#9

In general, visitor will use www.ookangzheng.com visit my site.

I want to hide my server IPv4 and v6. So I turn on Cloudflare’s proxies ~~

0 Likes

#10

All right, in that case you should not unproxy anything. So the current setup should be okay then.

1 Like