Unable to use R2, stuck at "Add R2 subscription to your account"

i signup because i need R2 service, i added my company CC to billing and proceed to add R2 to my account. I click on the blue button with “Add R2 subscription to your account” and the page reloads with the same page and button. It’s stuck in a loop and i can’t get to use the service.

i tried submitting a ticket but has been useless, only a waste of time.
i tried with different browser and i get to the same problem. I also emptied the cache but got the same result. how to solve this? how can i finally manage to use R2?

Could you share a ticket here with us so I could escalate this to the CF team? :thinking:

Was it a credit card? Have you maybe tried via PayPal in the meantime? :thinking:

hi @fritex ticket is #3138896

about billing, i put my company bank account to enable the R2 service. Now if i click on R2 on the left it shows me the R2 page that ends with route “/plans” with the “Add R2 subscription to my account” blue button, when i click the button it reloads the same page. In the ticket there is a screenshot of the page. Under the button there is the text:

“We will use the existing credit card on file (xxxx-xxxx-xxxx-xxxx)
You will only be charged if you exceed the monthly limits.”

I cannot try with paypal because when i click on R2 it loads this page and i cannot do anything else.

not sure if this can help but i noticed that in the console, after i click on the “Add R2 subcription…” button, i get the error:

 TypeError: Failed to fetch
     at static.dash.cloudflare.com/c04b84e8ab1364fc701c.js:76:2395
     at async A (static.dash.cloudflare.com/9cae787b1e586625727f.js:46:4387)

and then reload the same page with route “/plans”

I have re-opened ticket #3138896 with our “billing” team, so they can work to remedy this issue. I apologize with the delay in this request.

1 Like

I am having this exact same issue, can you please help?

thanks

support fixed for me after a few days from my post

1 Like

I am having this exact same issue, can you please help?

Thanks!