Unable to use Cloudflare Public DNS even while showing active


I am trying to setup Cloudflare DNS, but all DNS leak testing website shows that I am using OpenDNS or Google.

Why this is happening?


DNS leak test website shows below details

DNS IP ISP Country OpenDNS, LLC Singapore

Flush your DNS cache and/or check your router to ensure it’s not forcing clients to use it’s DNS.

You should also have a look at the following resources.


Simple DNSCrypt

to get Encrypted SNI, you’ll need to setup Firefox Nightly

My ISP says, on PPPoE connection you cannot change the default DNS resolver. Is it true I really cannot change?

Update: Using Simple DNSCrypt, finally I could change to Cloudflare DNS. :smiley:



Thanks a lot. Finally, I am able to use Cloudflare DNS. It’s really fast.

1 Like

I’d leave the router settings alone unless you’re feeling adventurous. If you are, be sure to document your current PPPoE settings just in case things go South.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.